Modify

Opened 11 years ago

Closed 9 years ago

#5591 closed defect (fixed)

Importvec plugin overwrites "Open" button in toolbar

Reported by: Claudius Owned by: Upliner
Priority: normal Milestone:
Component: Plugin importvec Version:
Keywords: Cc:

Description (last modified by Don-vip)

How to reproduce:

  • Load "importvec" plugin
  • Check first icon in JOSM toolbar

Result:
Default first icon in JOSM toolbar is "open file". After installation of importvec plugin it's replaced by "Import vector graphics" action.
User cannot fixt this using preference -> toolbar, because everytime he/she puts File->Open command in toolbar it's replaced by vector import.

Expected result:
Plugin installation should not change default toolbar behaviour.

JOSM version: 3640
Plugin version: 23715

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by Don-vip

Component: PluginPlugin importvec
Description: modified (diff)
Owner: changed from team to Upliner

comment:2 Changed 9 years ago by Upliner

Resolution: fixed
Status: newclosed

This thing is already fixed for years

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.