Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5417 closed defect (fixed)

Failed to parse date

Reported by: Ldp Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

JOSM 3514

Attempting to upload to a closed changeset:

PUT http://api.openstreetmap.org/api/0.6/changeset/5708098... Conflict
Error header: The changeset 5708098 was closed at 2010-09-07 14:39:41 UTC
Failed to parse date '2010-09-07 14:39:41 UTC' replied by server.


java.text.ParseException: Unparseable date: "2010-09-07 14:39:41 UTC"
        at java.text.DateFormat.parse(Unknown Source)
        at org.openstreetmap.josm.io.ChangesetClosedException.parseErrorHeader(ChangesetClosedException.java:81)
        at org.openstreetmap.josm.io.ChangesetClosedException.<init>(ChangesetClosedException.java:111)
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:586)
        at org.openstreetmap.josm.io.OsmApi.sendRequest(OsmApi.java:477)
        at org.openstreetmap.josm.io.OsmApi.updateChangeset(OsmApi.java:352)
        at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:194)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:236)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
java.lang.reflect.InvocationTargetException
        at java.awt.EventQueue.invokeAndWait(Unknown Source)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:88)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at java.util.Calendar.setTime(Unknown Source)
        at java.text.SimpleDateFormat.format(Unknown Source)
        at java.text.SimpleDateFormat.format(Unknown Source)
        at java.text.DateFormat.format(Unknown Source)
        at org.openstreetmap.josm.tools.ExceptionUtil.explainChangesetClosedException(ExceptionUtil.java:247)
        at org.openstreetmap.josm.gui.ExceptionDialogUtil.explainChangesetClosedException(ExceptionDialogUtil.java:58)
        at org.openstreetmap.josm.gui.ExceptionDialogUtil.explainOsmTransferException(ExceptionDialogUtil.java:403)
        at org.openstreetmap.josm.gui.ExceptionDialogUtil.explainException(ExceptionDialogUtil.java:478)
        at org.openstreetmap.josm.gui.io.AbstractUploadTask.handleFailedUpload(AbstractUploadTask.java:353)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask$2.run(UploadPrimitivesTask.java:322)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.finish(UploadPrimitivesTask.java:351)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:90)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.Dialog$1.run(Unknown Source)
        at java.awt.Dialog$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Dialog.show(Unknown Source)
        at java.awt.Component.show(Unknown Source)
        at java.awt.Component.setVisible(Unknown Source)
        at java.awt.Window.setVisible(Unknown Source)
        at java.awt.Dialog.setVisible(Unknown Source)
        at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by bastiK

Priority: normalmajor

comment:2 Changed 10 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3562]) fixed #5417 - Failed to parse date

comment:3 Changed 10 years ago by bastiK

Ticket #5340 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by bastiK

Ticket #5483 has been marked as a duplicate of this ticket.

comment:5 Changed 10 years ago by bastiK

Ticket #5505 has been marked as a duplicate of this ticket.

comment:6 Changed 10 years ago by anonymous

Ticket #5516 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.