Modify

Opened 9 years ago

Closed 8 years ago

#5326 closed defect (fixed)

Exception in plugin Routing (22549) when opening data file or downloading data

Reported by: willis@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM
  2. Open data file *.osm or download data
  3. Exception at the end of download or file opening

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-08-13 10:44:46
Last Changed Author: ulfl
Revision: 3429
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-08-12 11:17:59 +0200 (Thu, 12 Aug 2010)
Last Changed Rev: 3429

Identification: JOSM/1.5 (3429 de)
Memory Usage: 42 MB / 989 MB (9 MB allocated, but free)
Java version: 1.6.0_21, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Plugin: routing (22549)

org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin routing aufgetreten.
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:32)
	at org.openstreetmap.josm.plugins.PluginHandler.notifyMapFrameChanged(PluginHandler.java:740)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:184)
	at org.openstreetmap.josm.Main.addLayer(Main.java:231)
	at org.openstreetmap.josm.io.OsmImporter$1.run(OsmImporter.java:48)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.Dialog$1.run(Unknown Source)
	at java.awt.Dialog$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:29)
	... 26 more
Caused by: java.lang.NullPointerException: /images//cursor/modifier/move.png not found
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:75)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:257)
	at org.openstreetmap.josm.tools.ImageProvider.overlay(ImageProvider.java:275)
	at org.openstreetmap.josm.tools.ImageProvider.getCursor(ImageProvider.java:263)
	at com.innovant.josm.plugin.routing.actions.MoveRouteNodeAction.<init>(MoveRouteNodeAction.java:87)
	at com.innovant.josm.plugin.routing.RoutingPlugin.mapFrameInitialized(RoutingPlugin.java:179)
	... 31 more

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3436]) fixed #5326 by reverting [2981] (Ticket text: Exception in plugin Routing (22549) when opening data file or downloading ...)

comment:2 Changed 9 years ago by stoecker

Resolution: fixed
Status: closedreopened

Please instead of moving images into the main tree, which will be removed by next cleanup again, add them to the plugin itself, so it will be accessible in any case.

comment:3 Changed 9 years ago by bastiK

Yes, i realized that when i was done :)

comment:4 Changed 8 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.