Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5280 closed defect (duplicate)

Map window does not get focus right away

Reported by: skyper Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: map focus Cc:

Description

The map (main) window does not get the focus right away, instead you have to click to get focus.

  1. select all members of a relation.
  2. move with the mouse to the map.
  3. try to delete these objects pressing "DEL".

The selected objects remain but the relation is deleted.

to delete the objects, I have to click to the map to get the focus an then reselect the objects.

This can lead to delete relations. That is why I think it is critical.

skyper

r3391, openjdk, ubuntu 10.4, xfwm with focus follow mouse set.

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by skyper

I also noticed that pop-up windows(eg download object by id) do not get the focus right away. This is nasty, too, but not that important.

comment:2 Changed 11 years ago by bastiK

Resolution: duplicate
Status: newclosed

comment:3 Changed 11 years ago by bastiK

Closed as duplicate of #3278.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.