Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#5174 closed defect (fixed)

Validator: Incorrectly claims node is untagged

Reported by: AM909 Owned by: team
Priority: critical Milestone:
Component: Core validator Version:
Keywords: untagged Cc: AM909

Description

Validator incorrectly claims that node 583031681, which has a single tag of note="FIXME:...", is an "Untagged and unconnected node".

Attachments (0)

Change History (35)

comment:1 Changed 11 years ago by stoecker

Resolution: wontfix
Status: newclosed

FIXME is not accepted as valid tag.

comment:2 Changed 11 years ago by AM909

Resolution: wontfix
Status: closedreopened

I don't understand.

  • It claims the node is untagged, not that the tag is invalid
  • The tag is k="note" + v="FIXME:something...", not k="FIXME" + v="something..."
  • "FIXME" is a valid key according to the wiki, as are "fixme" and "note", and all three are important and widely used. People should not be led to delete these nodes by the validator.

comment:3 Changed 11 years ago by stoecker

Resolution: wontfix
Status: reopenedclosed

It does not contain any useful data. Note and fixme as well as some others are just description texts. There is nothing else which describes what the node is, so it is correctly detected as untagged. If there is nothing else like amenity, landuse, shop, .... whatever, then the node has no specification.

Untagged checks leaves out everything which does not carry information and checks if there is left anything afterwards. The untagged check would be pretty useless if we didn't leave out these common non-tagging tags.

comment:4 in reply to:  3 Changed 11 years ago by AM909

Replying to stoecker:

If there is nothing else like amenity, landuse, shop, .... whatever, then the node has no specification.

I disagree. The specification is that it is a note for the benefit of mappers - a note that should not be removed.

Untagged checks leaves out everything which does not carry information and checks if there is left anything afterwards. The untagged check would be pretty useless if we didn't leave out these common non-tagging tags.

No, it wouldn't. I (and many others I'm sure) use it to remove the real unconnected nodes that some editor bug is leaving all over the place when someone deletes the way that used to contain them. I commonly select that item in the list and delete these nodes. I just happened to notice this time that there was a "note" tag in the properties dialog - a detail that is likely to be overlooked by most.

If the validator continues to claim (incorrectly according to the wiki) that these nodes are "untagged", people _will_ accidentally remove them. I can add foo=bar to them to keep them from being flagged as untagged, but that seems like a ridiculous hack. What should I (and others) do to keep our hard work from being destroyed?

comment:5 Changed 11 years ago by bastiK

Resolution: wontfix
Status: closedreopened

comment:6 Changed 11 years ago by bastiK

There is a difference between edited_by=*, source=*, note=*, FIXME=*. The first is useless, the second should not be deleted without understanding why it is there and the latter 2 shouldn't be removed at all. If validator leads to accidental removal of those objects, it is an issue.

comment:7 Changed 11 years ago by anonymous

note=FIXME foo is an alternate way of tagging FIXME=foo. Handling them differently is a bug.

comment:8 Changed 11 years ago by NE2

silly thing keeps logging me out... that's me above.

comment:9 Changed 11 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

In [o22004] now text distinguish between totally untagged and untagged but commented.

comment:10 Changed 11 years ago by anonymous

Resolution: fixed
Status: closedreopened

It's still not fixed if it treats note=FIXME foo and FIXME=foo differently.

comment:11 Changed 11 years ago by NE2

me again...

comment:12 Changed 11 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

(In [3341]) added some more uninteresting keys - fixes #5174

comment:13 Changed 11 years ago by NE2

Resolution: fixed
Status: closedreopened

Um... if I'm reading that diff correctly, it now treats something tagged only FIXME as "uninteresting" and thus lumped in with stuff tagged only created_by and the like? This is exactly the wrong way to go, and will lead to more, not less, improper deletions of nodes so tagged. (Even though it's now in a different "untagged but commented" category, said category will mostly include garbage anyway, and people may not realize that some comments are to be kept.)

comment:14 Changed 11 years ago by stoecker

Owner: changed from team to AM909
Status: reopenedneedinfo

I still see no sense in having "comment only" nodes and ways. So the approach to handle them as uninteresting is right. The same is true for the validator to show them. I agree that untagged and tagged but uninteresting may be different, thats why I added the different texts.

Please tell me a proper usage of plain-uninteresting node tagging and I maybe will change my opinion, but I don't think so. These aren't available to any processing whether map generation, routing or something else. So they don't provide any real value.

comment:15 Changed 11 years ago by bastiK

[3341] is a regression as you can no longer visually see if a node is tagged as FIXME=continue.

The proper way to handle it would be a Fixme style that is on by default an can be toggled very easily (e.g. View -> Styles -> (x) Fixme highlighting)

Until this is done, fixme shouldn't be uninteresting.

comment:16 Changed 11 years ago by stoecker

Why don't you add an icon for "fixme=..." and "FIXME=...", e.g. a little red x or something like this (with lowest priority, so it wont overwrite other icons)?

I don't like the idea to have dozens of explicitely coded node tagging styles. We have mappaint styles for this.

comment:17 in reply to:  14 Changed 11 years ago by NE2

Replying to stoecker:

I still see no sense in having "comment only" nodes and ways. So the approach to handle them as uninteresting is right. The same is true for the validator to show them. I agree that untagged and tagged but uninteresting may be different, thats why I added the different texts.

Please tell me a proper usage of plain-uninteresting node tagging and I maybe will change my opinion, but I don't think so. These aren't available to any processing whether map generation, routing or something else. So they don't provide any real value.

http://www.openstreetmap.org/browse/node/789307752

keepright displays these (as does the JOSM validator under the "fixmes" category).

comment:18 in reply to:  16 Changed 11 years ago by bastiK

Replying to stoecker:

Why don't you add an icon for "fixme=..." and "FIXME=...", e.g. a little red x or something like this (with lowest priority, so it wont overwrite other icons)?

sound good.

I don't like the idea to have dozens of explicitely coded node tagging styles. We have mappaint styles for this.

Basically I was referring to a FIXME mappaint style for nodes and ways. (Similar to current maxspeed style.)

comment:19 Changed 11 years ago by anonymous

Owner: changed from AM909 to team
Status: needinfonew

@NE2: Actually your example does validate my opinion:

  • This fixme does not carry any information at all (it is like a bug report telling me there is a bug, but not what the bug is).
  • If someone thinks it is necessary, then OpenStreetBugs is a much better place to have it.

I leave the bug open due to the mappaint issue to have a better display for fixme nodes.

comment:20 Changed 11 years ago by NE2

If you don't understand the issue, maybe you should leave it to someone who does...

comment:21 Changed 11 years ago by stoecker

It is a dumb idea to insult the software maintainer when you want something changed. It reduces your chances to be taken serious a lot (which you BTW did right now).

comment:22 Changed 11 years ago by NE2

Insults beget insults.

comment:23 Changed 11 years ago by stoecker

Resolution: fixed
Status: newclosed

Added icon in r3345.

comment:24 Changed 11 years ago by NE2

Resolution: fixed
Status: closedreopened

That's still not fixed... as long as the validator treats a node with only FIXME=* or note=FIXME * the same as one with only source=*, this will be a defect.

comment:25 Changed 11 years ago by Landwirt

Priority: normalcritical

Marking nodes tagged with note, comment and fixme as untagged combined with an repair feature that deletes them without any question is just wrong and a critical defect.
The existence of OSB and other tools does not invalidate such nodes nor is it the job of the editor to decide which comments and notes are useful or uninteresting.

comment:26 Changed 11 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

Further reopenings of this ticket will be deleted without comment.

comment:28 in reply to:  26 Changed 11 years ago by Landwirt

Replying to stoecker:
# resolution set to fixed

Well, when was it fixed? I run latest 3345 with validator 22004. If I create a node with only fixme, note or comment it is marked as untagged and removed when I click on repair.

comment:29 Changed 11 years ago by stoecker

@Landwirt:
You now have two different texts for untagged and "untagged, but with comment". I still think the correct reaction is to delete these nodes (I would do so by hand as well when I would encounter them). In case you have a suggestion for a better wording for the error, then we can change it.

comment:30 in reply to:  29 Changed 11 years ago by anonymous

Replying to stoecker:

@Landwirt:
You now have two different texts for untagged and "untagged, but with comment". I still think the correct reaction is to delete these nodes (I would do so by hand as well when I would encounter them). In case you have a suggestion for a better wording for the error, then we can change it.

Why would you delete these nodes that clearly represent important information to the person that put them there (and perhaps others)? When I go to [re-]survey an area, I specifically look for these so I can make sure I survey the subject. They are an important part of my workflow, which I will remind you is substantial, and free (as is yours). It is a lightweight, fast solution to a need. If you were to poll other users, I believe they will be on our side.

comment:31 Changed 11 years ago by AM909

That's my comment above. Sure would be nice if it would leave me logged in, or make a point of warning you that you are anonymous.

comment:32 Changed 11 years ago by NE2

Resolution: fixed
Status: closedreopened

comment:33 Changed 11 years ago by NE2

stoecker: if you purposely deleted these nodes, it would be vandalism. I guess you could call purposely making it easy for JOSM users to delete them without realizing institutionalized vandalism?

comment:34 Changed 11 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

(In [o22043]) add more sub-categories for unconnected nodes with no physical tags. (fixes #5174)

comment:35 Changed 11 years ago by bastiK

It is ok to have bare nodes with FIXME and it shouldn't be deleted. (Some people even put comments in source code even though it has no meaning to the compiler whatsoever.) Obviously OSB or putting the comment on a real object should be preferred, but others may choose otherwise and we shouldn't force our opinion upon them.

comment:36 Changed 11 years ago by NE2

If this change does what it should, thank you.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.