Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#5134 closed defect (fixed)

bogus warnings "failed to locate image"

Reported by: bastiK Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

JOSM shows errors

Fatal: failed to locate image 'images/preferences/walkingpapers.png'. This is a serious configuration problem. JOSM will stop working.

when downloading the plugin list from server.

Note: It is expected that the image is not there, but only ImageProvider.getIfAvailable(...) is used, which shouldn't show this warning.

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by stoecker

getIfAvailable() issues this warning, this is intended. The normal get() raises an exception.

comment:2 Changed 10 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3331]) fixed #5134 - bogus warnings "failed to locate image". Fixed the cause for the warnings instead.

comment:3 Changed 10 years ago by bastiK

OK, maybe issue a new build, so people don't get confused by this.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.