Modify

Opened 12 years ago

Closed 7 years ago

#4998 closed defect (fixed)

Impossible to select nodes with filter

Reported by: stoecker Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description (last modified by aceman)

When e.g. a street and a languse overlap using the same nodes, then it is impossible to select one of the nodes when languse is filtered. Always the whole way is selected.

It seems nodes of filtered objects aren't taken into account for selection even if they are also unfiltered.

Probably they should be a warning (e.g. in filter display), but they should be selectable.

Attachments (0)

Change History (11)

comment:1 Changed 12 years ago by bastiK

I guess you have "apply also for children" checkbox ticked. Then these nodes are indeed filtered and this is the expected behaviour.

But it shouldn't be like this. First it's not good to put both, "nodes of a way" and "members of a relaion", in one option. I don't think we need the latter option at all, because it might cause confusion more often than it is useful. And it can be easily simulated with search patern like child (type:relation boundary=administrative).

I'd suggest to remove the "C" option completely and apply sensible default behaviour instead:

  • If a way is not filtered, all its nodes are not filtered.
  • If a way is filtered, all untagged nodes are filtered as well, unless the first rule applies.
  • If a filter applies explicitly for a node then forget about the first two rules and filter it.

comment:2 Changed 12 years ago by stoecker

Suggestion sounds good to me.

comment:3 Changed 12 years ago by stoecker

Ticket #5050 has been marked as a duplicate of this ticket.

comment:4 in reply to:  3 Changed 12 years ago by anonymous

Replying to stoecker:

Ticket #5050 has been marked as a duplicate of this ticket.

Suggestion from the ticket

To prevent false moved nodes, the position should be locked (e.g. marked as red x).
If you want to delete the node, it should only be removed from the displayed ways and
disappear. (but not be deleted)

comment:5 Changed 12 years ago by stoecker

Priority: normalmajor

comment:6 Changed 12 years ago by bastiK

(In [3300]) see #4998 - Impossible to select nodes with filter

comment:7 Changed 12 years ago by bastiK

First attempt to fix this. It should cover the basic cases but definitely needs some testing.

I think for the search modes 'remove' and 'find in selection' it is not optimal yet (shows superfluous nodes). But I have problems to imagine what these are used for so better hide too view than too much.

comment:8 Changed 8 years ago by aceman

Description: modified (diff)

I think I was hit by this in current trunk. I wanted to split a way that was unfiltered and selected, on a node that was part of another filtered way. It was not possible to select the node.
Is the patch from comment 6 checked in yet?

comment:9 in reply to:  8 Changed 8 years ago by bastiK

Replying to aceman:

I think I was hit by this in current trunk. I wanted to split a way that was unfiltered and selected, on a node that was part of another filtered way. It was not possible to select the node.
Is the patch from comment 6 checked in yet?

More details needed: .osm file and detailed filter description (from preferences.xml or screenshot)

comment:10 Changed 8 years ago by aceman

Somehow I can't reproduce it at the place I thought I have seen the problem. I'll come back if I see it again.

comment:11 Changed 7 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.