Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4979 closed defect (fixed)

Exception when opening the download window

Reported by: andre68@… Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: template_report Cc:


What steps will reproduce the problem?

  1. Click on download button or select "download from server" from menu.

What is the expected result?
It should open the download window.

What happens instead?
Nothing. Immediate exception.

Please provide any additional information below. Attach a screenshot if

Falling back to version 3213 works.

Build-Date: 2010-05-03 07:11:05
Revision: 3214
Is-Local-Build: true

Memory Usage: 22 MB / 508 MB (8 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

Plugins: editgpx,measurement,multipoly,openstreetbugs,osmarender,photo_geotagging,remotecontrol,slippymap,turnrestrictions,validator,waydownloader,wmsplugin
Plugin openstreetbugs (Version: 20696)
Plugin wmsplugin (Version: 20891)
Plugin editgpx (Version: 19683)
Plugin remotecontrol (Version: 19946)
Plugin validator (Version: 20799)
Plugin slippymap (Version: 19887)
Plugin waydownloader (Version: 19489)
Plugin osmarender (Version: 19419)
Plugin photo_geotagging (Version: 19873)
Plugin turnrestrictions (Version: 21010)
Plugin multipoly (Version: 19456)
Plugin measurement (Version: 19681)

java.lang.ClassCastException: cannot be cast to java.lang.String
	at org.openstreetmap.josm.gui.widgets.ComboBoxHistory.addElement(
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(
	at javax.swing.AbstractButton.fireActionPerformed(
	at javax.swing.AbstractButton$Handler.actionPerformed(
	at javax.swing.DefaultButtonModel.fireActionPerformed(
	at javax.swing.DefaultButtonModel.setPressed(
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
	at java.awt.AWTEventMulticaster.mouseReleased(
	at java.awt.Component.processMouseEvent(
	at javax.swing.JComponent.processMouseEvent(
	at java.awt.Component.processEvent(
	at java.awt.Container.processEvent(
	at java.awt.Component.dispatchEventImpl(
	at java.awt.Container.dispatchEventImpl(
	at java.awt.Component.dispatchEvent(
	at java.awt.LightweightDispatcher.retargetMouseEvent(
	at java.awt.LightweightDispatcher.processMouseEvent(
	at java.awt.LightweightDispatcher.dispatchEvent(
	at java.awt.Container.dispatchEventImpl(
	at java.awt.Window.dispatchEventImpl(
	at java.awt.Component.dispatchEvent(
	at java.awt.EventQueue.dispatchEvent(
	at java.awt.EventDispatchThread.pumpOneEventForFilters(
	at java.awt.EventDispatchThread.pumpEventsForFilter(
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(
	at java.awt.EventDispatchThread.pumpEvents(
	at java.awt.EventDispatchThread.pumpEvents(

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3215]) fixed #4979 Exception when opening the download window; fixed #2221 - Unexcepted Exception when typing into "Change values?" box with an input method on Mac OS X

comment:2 Changed 8 years ago by stoecker

Ticket #4980 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.