Modify

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4971 closed defect (fixed)

NullPointerException at OsmReader.java:586, caused by NullPointerException at Storage.java:317

Reported by: Adam Dunn Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

When attempting to open attached osm file, a NullPointerException is thrown. The file was not generated by me, but I will be able to get more information on how it was generated. Using Eclipse to debug, a breakpoint can be set for Storage:317 with a hit count of 370 (to zoom ahead to the error-causing node in the osm file). It appears that the error occurs on or near line 16217 of the osm file where node id -8043 is read. I'm not a JOSM programmer so this may not be the precise location of the problem, but it's close. This was tested with a fresh subversion checkout of revision 3213 of JOSM. The variable being passed appears to be null, going back to at least OsmReader:273, where key and value are both null.

Attachments (2)

082H04_Sample.osm (703.0 KB) - added by Adam Dunn 9 years ago.
The offending osm file
stacktrace.txt (2.9 KB) - added by Adam Dunn 9 years ago.
Stacktrace

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Adam Dunn

Attachment: 082H04_Sample.osm added

The offending osm file

Changed 9 years ago by Adam Dunn

Attachment: stacktrace.txt added

Stacktrace

comment:1 Changed 9 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3217]) fixed #4971 NullPointerException at OsmReader.java:586, caused by NullPointerException at Storage.java:317;
fixed #4964 exception undo "node-merge" with nodes children of relations.

comment:2 Changed 9 years ago by bastiK

The line <tag/> is rejected because it does not provide key and value information. I added appropriate error message.

comment:3 Changed 9 years ago by Adam Dunn

Thanks for looking into this. I can now submit more concrete information about the problem to the person who generated the file.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.