Modify

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4935 closed defect (fixed)

Wireframe painting broken for high zoom

Reported by: framm Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: painting java clipping Cc:

Description

When zooming in rather far in wireframe mode, erratic lines appear. From the colour of the lines it seems to have something to do with the "relation halo".

See the following video, which has been recorded by simply using the mouse wheel to zoom in further and furhter:

http://www.remote.org/frederik/tmp/josm-wireframe-broken.ogv

Attachments (0)

Change History (8)

comment:1 Changed 10 years ago by bastiK

You are using OpenJDK, right?

I already thought about encoding basic information like revision, os and java vendor into the upper left map pixel. :)

comment:2 Changed 10 years ago by stoecker

I assume this happens when we draw to much outside the current screen. I fear this is not only for OpenJDK, I also had this for SunJava and GPX files, but the improved clipping code reduced the issue.

comment:3 in reply to:  2 Changed 10 years ago by bastiK

Replying to stoecker:

I assume this happens when we draw to much outside the current screen. I fear this is not only for OpenJDK, I also had this for SunJava and GPX files, but the improved clipping code reduced the issue.

If you are referring to [2987], it affects only openjdk. (I was concerned about performance, but now that I think of it, should be really cheap to do this clipping.)

comment:4 Changed 10 years ago by bastiK

No, it does not even apply for gpx files. I think jttt did some purging of gpx line segments that do not intersect the current view.

comment:5 Changed 10 years ago by stoecker

See #4040.

comment:6 Changed 9 years ago by anonymous

Ticket #5027 has been marked as a duplicate of this ticket.

comment:7 Changed 9 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3243]) fixed #4935 - Wireframe painting broken for high zoom

comment:8 Changed 9 years ago by stoecker

Keywords: painting java clipping added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.