Modify

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#4842 closed defect (fixed)

Combine ways silently combines when tag is not present on one way but present on the other

Reported by: AM909 Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: combine tag Cc: AM909

Description (last modified by skyper)

If you have a way with layer=1 and another way with no layer tag, and you combine them, the conflict dialog comes up but just says "no conflicts". The new way will have layer=1, which may be incorrect.

I can't think of any cases where it should do this. There are probably some "who cares" cases (like created_by), but it's still not technically correct.

Attachments (1)

bug_4842_example.osm (216.6 KB) - added by skyper 8 years ago.
example

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by skyper

Keywords: combine tag added
Priority: normalmajor

comment:2 Changed 10 years ago by stoecker

Ticket #5113 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by AM909

Cc: AM909 added
Version: tested

This happens only when you have checked the "Show tags with multiple values only" checkbox at the top of the conflict dialog. It apparently is not considering "no key" as a value different than key=* when it counts how many values there are in the selection (but it should).

Additionally, when it brings up the conflict dialog with "no conflicts" in this case, the checkboxes at the top are not present, so you need to create conflicting tags and then try to combine them in order to change the settings of those checkboxes, which is not ideal - they should appear even in the "no conflicts" case.

Confirmed present in r3329.

comment:4 Changed 8 years ago by stoecker

Owner: changed from team to AM909
Status: newneedinfo

Sorry. Can't reproduce here at all. Please make a step-for-step description.

Note that no conflicts are produced, when a way is totally untagged.

comment:5 in reply to:  4 Changed 8 years ago by skyper

Replying to Am909:

Replying to stoecker:

This happens only when you have checked the "Show tags with multiple values only" checkbox at the top of the conflict dialog. It apparently is not considering "no key" as a value different than key=* when it counts how many values there are in the selection (but it should).

Additionally, when it brings up the conflict dialog with "no conflicts" in this case, the checkboxes at the top are not present, so you need to create conflicting tags and then try to combine them in order to change the settings of those checkboxes, which is not ideal - they should appear even in the "no conflicts" case.

Sorry. Can't reproduce here at all. Please make a step-for-step description.

At least the problem mentioned by Am909 still exists. Once you have checked on of the two chechboxes on top this setting is stored and you do not get any information about it on the next connect, if there are no unfiltered differences.

Please always show the two checkboxes on top to get the information about the filter and be able to switch back to no filter. (uncheck the boxes).

Thanks

comment:6 Changed 8 years ago by stoecker

As said I was unable to reproduce, so you do something different than I do. I need a better description.

comment:7 Changed 8 years ago by skyper

Owner: changed from AM909 to team
Status: needinfonew

Not the best example but you should get the clue.

  1. combine the two ways and check both checkboxes on top.
  2. undo
  3. combine the two ways -> only differences in relation membership are listed. There are no checkboxes on top and if there is a tag in without a conflict on one way, you will not get any info.
  4. to uncheck the boxes again you have to create a conflict on a tag.

Changed 8 years ago by skyper

Attachment: bug_4842_example.osm added

example

comment:8 Changed 8 years ago by skyper

Description: modified (diff)

still reproducable with r4707

comment:9 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

In 5090/josm:

fix #4842 - Combine ways silently combines when tag is not present on one way but present on the other

comment:10 in reply to:  9 Changed 8 years ago by skyper

Replying to simon04:

In 5090/josm:

fix #4842 - Combine ways silently combines when tag is not present on one way but present on the other

Thanks a lot !

comment:11 Changed 8 years ago by skyper

Resolution: fixed
Status: closedreopened

Now it raises conflicts even with untagged objects.

I have an node with addr:housenumber=19 as tag and part of a associatedStreet relation and merge it with a node id:0 with no tages but part of a closed way and I get the tag conflict dialogue shown.

Last edited 8 years ago by skyper (previous) (diff)

comment:12 Changed 8 years ago by simon04

Resolution: fixed
Status: reopenedclosed

The bug has been introduced in r5132 and isn't related to this fix.

comment:13 in reply to:  12 ; Changed 8 years ago by skyper

Replying to simon04:

The bug has been introduced in r5132 and isn't related to this fix.

Thanks, next time I will open a new ticket if I am unsure.

comment:14 in reply to:  13 Changed 8 years ago by simon04

Replying to skyper:

Thanks, next time I will open a new ticket if I am unsure.

No problem. :-)

I'm happy to hear your opinion on comment:8:ticket:7513

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.