Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4817 closed defect (duplicate)

bug unhandled exception

Reported by: dieterdreist Owned by: dieterdreist
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-28 01:31:26
Last Changed Author: bastiK
Revision: 3160
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-27 19:55:11 +0100 (Sat, 27 Mar 2010)
Last Changed Rev: 3160

Memory Usage: 175 MB / 1016 MB (74 MB allocated, but free)
Java version: 1.6.0_16, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux

Dataset consistency test:
[SEARCH NODES] {Node id=-4782 version=0 V lat=52.509541474066125,lon=13.416540383394219} not found using Dataset.searchNodes()
[SEARCH NODES] {Node id=-4782 version=0 V lat=52.509541474066125,lon=13.416540383394219} not found using Dataset.searchNodes()

Plugins: AddrInterpolation,Create_grid_of_ways,DirectUpload,buildings_tools,colorscheme,dataimport,editgpx,measurement,multipoly,openstreetbugs,openvisible,osmarender,public_transport,remotecontrol,terracer,validator,walkingpapers,waydownloader,wmsplugin
Plugin openstreetbugs (Version: 20683)
Plugin dataimport (Version: 20431)
Plugin validator (Version: 20579)
Plugin osmarender (Version: 19419)
Plugin AddrInterpolation (Version: 19422)
Plugin terracer (Version: 20084)
Plugin measurement (Version: 19681)
Plugin multipoly (Version: 19456)
Plugin walkingpapers (Version: 19487)
Plugin colorscheme (Version: 19426)
Plugin wmsplugin (Version: 20566)
Plugin editgpx (Version: 19683)
Plugin Create_grid_of_ways (Version: 19428)
Plugin openvisible (Version: 20067)
Plugin public_transport (Version: 20673)
Plugin remotecontrol (Version: 19946)
Plugin DirectUpload (Version: 19700)
Plugin buildings_tools (Version: 20269)
Plugin waydownloader (Version: 19489)

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Node id=-4782 version=0 V lat=52.509541474066125,lon=13.416540383394219}

at org.openstreetmap.josm.data.osm.OsmPrimitive.checkDataset(OsmPrimitive.java:169)
at org.openstreetmap.josm.data.osm.OsmPrimitive.getReferrers(OsmPrimitive.java:946)
at org.openstreetmap.josm.data.osm.Node.isJunctionNode(Node.java:200)
at org.openstreetmap.josm.gui.mappaint.SimpleNodeElemStyle.paintPrimitive(SimpleNodeElemStyle.java:28)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPaintVisitor.drawNode(MapPaintVisitor.java:132)
at org.openstreetmap.josm.data.osm.visitor.paint.MapPaintVisitor.visitAll(MapPaintVisitor.java:748)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.paint(OsmDataLayer.java:268)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:533)
at javax.swing.JComponent.paintChildren(JComponent.java:864)
at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1030)
at javax.swing.JComponent.paint(JComponent.java:1038)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5124)
at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1475)
at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1406)
at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:294)
at javax.swing.RepaintManager.paint(RepaintManager.java:1220)
at javax.swing.JComponent._paintImmediately(JComponent.java:5072)
at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:803)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:714)
at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:694)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:128)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (5)

comment:1 Changed 10 years ago by dieterdreist

Priority: normalcritical

cannot continue, dataloss. Happened while drawing a way with "plus" in select mode

comment:2 in reply to:  1 Changed 10 years ago by dieterdreist

Priority: criticalmajor

Replying to dieterdreist:

cannot continue, dataloss. Happened while drawing a way with "plus" in select mode

OK, could upload. No data lost. But some minutes later it happened again. It seems to happen on (some?) undo-actions. If I recall right, also the first time it happened after an undo (that I tried to do after adding a node by dragging the "plus").

comment:3 Changed 10 years ago by stoecker

Owner: changed from team to dieterdreist
Status: newneedinfo

Could you make this reproducable?

comment:4 Changed 10 years ago by jttt

Resolution: duplicate
Status: needinfoclosed

comment:5 Changed 10 years ago by anonymous

Closed as duplicate of #4815.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dieterdreist.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.