Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4804 closed defect (duplicate)

[PATCH] bug in OsmApi capabilities parsing

Reported by: eric.marsden@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Please see patch below: SAX parsing is incorrectly iterating on qName.length() instead of atts.getLength().

This bug seems to be silently ignored by openjdk6, but causes problems with classpath-based JVMs.

Index: src/org/openstreetmap/josm/io/OsmApi.java
===================================================================
--- src/org/openstreetmap/josm/io/OsmApi.java	(révision 3157)
+++ src/org/openstreetmap/josm/io/OsmApi.java	(copie de travail)
@@ -121,7 +121,7 @@
         }
 
         @Override public void startElement(String namespaceURI, String localName, String qName, Attributes atts) throws SAXException {
-            for (int i=0; i< qName.length(); i++) {
+            for (int i=0; i< atts.getLength(); i++) {
                 capabilities.put(qName, atts.getQName(i), atts.getValue(i));
             }
         }

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by bastiK

Summary: bug in OsmApi capabilities parsing[PATCH] bug in OsmApi capabilities parsing

comment:2 Changed 12 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:3 Changed 12 years ago by stoecker

Closed as duplicate of #4950.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.