Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4717 closed defect (duplicate)

Crash while drawing a closed way

Reported by: Raymond Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

While drawing i.e. a building with a closed way JOSM crashes at the moment you close the way at the start node.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-11 02:31:32
Last Changed Author: jttt
Revision: 3107
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-10 19:11:58 +0100 (Wed, 10 Mar 2010)
Last Changed Rev: 3107

Memory Usage: 100 MB / 247 MB (52 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows 7

Dataset consistency test:
No problems found

Plugins: terracer,validator,wmsplugin
Plugin wmsplugin Version: 19992
Plugin validator Version: 20366
Plugin terracer Version: 20084

java.lang.UnsupportedOperationException

at java.util.Collections$UnmodifiableCollection.clear(Unknown Source)
at org.openstreetmap.josm.actions.mapmode.DrawAction.mouseReleased(DrawAction.java:510)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by mjulius

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by mjulius

Closed as duplicate of #4705.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.