Modify

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4697 closed defect (fixed)

Attempting to download data around a place name.

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report namefinder Cc:

Description

What steps will reproduce the problem?

  1. Launch JOSM
  2. Search using Namefinder
  3. Enter city, press search

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-08 02:32:04
Last Changed Author: Gubaer
Revision: 3094
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-07 18:48:56 +0100 (Sun, 07 Mar 2010)
Last Changed Rev: 3094

Memory Usage: 81 MB / 81 MB (29 MB allocated, but free)
Java version: 1.6.0_17, Apple Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Mac OS X



java.lang.NullPointerException
	at org.openstreetmap.josm.gui.download.PlaceSelection$NameFinderResultParser.startElement(PlaceSelection.java:247)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:501)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:1359)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2747)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
	at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
	at org.openstreetmap.josm.gui.download.PlaceSelection$NameQueryTask.realRun(PlaceSelection.java:365)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:637)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.tools.I18n.gettext(I18n.java:73)
	at org.openstreetmap.josm.tools.I18n.tr(I18n.java:38)
	at org.openstreetmap.josm.gui.download.PlaceSelection$NameFinderResultParser.startElement(PlaceSelection.java:232)
	... 20 more

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by Claudius

Keywords: namefinder added

Cannot reproduce with r3126. Which name did you search for?

comment:2 Changed 9 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3256]) Fix #4697: Attempting to download data around a place name.

comment:3 Changed 9 years ago by jttt

I also couldn't reproduce it, but from stack trace it's clear that class attribute was missing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.