Modify

Opened 10 years ago

Closed 10 years ago

#4678 closed defect (fixed)

Problem while downloading data from OSM server with the pugin cadastre-fr activated

Reported by: hawkforce@… Owned by: pieren
Priority: normal Milestone:
Component: Plugin cadastre-fr Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. launch JOSM
  2. download data from OSM server

What is the expected result?

What happens instead?
No apparent problem, but the program sometimes stops without any more warning

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-03 02:31:44
Last Changed Author: Gubaer
Revision: 3070
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-02 20:55:48 +0100 (Tue, 02 Mar 2010)
Last Changed Rev: 3070

Memory Usage: 131 MB / 670 MB (88 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK 64-Bit Server VM
Operating system: Linux


Plugins: PicLayer,buildings_tools,cadastre-fr,dataimport,multipoly,nearclick,openstreetbugs,validator
Plugin openstreetbugs Version: 19463
Plugin PicLayer Version: 20217
Plugin dataimport Version: 20267
Plugin buildings_tools Version: 20269
Plugin validator Version: 20155
Plugin nearclick Version: 19458
Plugin multipoly Version: 19456
Plugin cadastre-fr Version: 19424

org.openstreetmap.josm.plugins.PluginException: Une erreur est survenue dans le greffon cadastre-fr
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:32)
	at org.openstreetmap.josm.plugins.PluginHandler.notifyMapFrameChanged(PluginHandler.java:688)
	at org.openstreetmap.josm.Main.setMapFrame(Main.java:180)
	at org.openstreetmap.josm.Main.addLayer(Main.java:229)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:157)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:90)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1464)
	at java.awt.Component.setVisible(Component.java:1416)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:29)
	... 27 more
Caused by: java.lang.NullPointerException: /images//cursor/modifier/move.png not found
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:75)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:246)
	at org.openstreetmap.josm.tools.ImageProvider.overlay(ImageProvider.java:268)
	at org.openstreetmap.josm.tools.ImageProvider.getCursor(ImageProvider.java:252)
	at cadastre_fr.WMSAdjustAction.<init>(WMSAdjustAction.java:39)
	at cadastre_fr.CadastrePlugin.mapFrameInitialized(CadastrePlugin.java:259)
	... 32 more

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by pieren

Resolution: fixed
Status: newclosed

This problem is already fixed. Either rebuild the plugin from sources or wait a little bit, a new version will be released soon.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pieren.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.