Modify

Opened 14 years ago

Closed 14 years ago

#4674 closed defect (fixed)

NPE in ToggleDialog

Reported by: anonymous Owned by: bastiK
Priority: normal Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description

error when activate the button for the osmbug-plugin

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-01 02:31:40
Last Changed Author: bastiK
Revision: 3063
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-28 21:22:34 +0100 (Sun, 28 Feb 2010)
Last Changed Rev: 3063

Memory Usage: 932 MB / 1016 MB (219 MB allocated, but free)
Java version: 1.6.0, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows Vista

Dataset consistency test:
No problems found

Plugins: PicLayer,ghost,openstreetbugs,remotecontrol,walkingpapers,wmsplugin
Plugin walkingpapers Version: 19487
Plugin openstreetbugs Version: 19463
Plugin wmsplugin Version: 19992
Plugin PicLayer Version: 19467
Plugin remotecontrol Version: 19946
Plugin ghost Version: 1

java.lang.NullPointerException

at org.openstreetmap.josm.gui.dialogs.ToggleDialog$ToggleDialogAction.actionPerformed(ToggleDialog.java:148)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.JToggleButton$ToggleButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 by Gubaer, 14 years ago

Owner: changed from team to anonymous
Status: newneedinfo
Summary: lübeckNPE in ToggleDialog

What is the "osmbug" plugin? the "openstreetbug" plugin from the OSM SVN or another plugin not maintained in the OSM SVN?

comment:2 by bastiK, 14 years ago

Owner: changed from anonymous to bastiK
Status: needinfonew

I had this as well, it's openstreetbug.

comment:3 by Gubaer, 14 years ago

Component: CorePlugin

comment:4 by mjulius, 14 years ago

(In [3087]) see #4674 - NPE in ToggleDialog

now throws IllegalArgumentException when ToggleDialogAction() gets no ToggleDialog to toggle.

comment:5 by bastiK, 14 years ago

Ticket #4731 has been marked as a duplicate of this ticket.

comment:6 by bastiK, 14 years ago

Resolution: fixed
Status: newclosed

In [o20463]

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.