Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4640 closed defect (duplicate)

LiveGPS Plugin not working in latest.

Reported by: anonymous Owned by: stoecker
Priority: normal Milestone:
Component: Plugin Version: latest
Keywords: GPS Live Plugin Cc:

Description

What steps will reproduce the problem?

  1. Startup Josm
  2. Download area map data
  3. Start gpsd-Service
  4. Enable Live-GPS logging

What is the expected result?

Logging of the current position-data from gps-device.

What happens instead?

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-01 02:31:40
Last Changed Author: bastiK
Revision: 3063
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-28 21:22:34 +0100 (Sun, 28 Feb 2010)
Last Changed Rev: 3063

Memory Usage: 47 MB / 493 MB (22 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK Server VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: DirectUpload,PicLayer,colorscheme,editgpx,livegps,measurement,multipoly,openstreetbugs,openvisible,plastic_laf,surveyor,tageditor,tagging-preset-tester,validator,walkingpapers,waydownloader,wmsplugin
Plugin plastic_laf Version: 14016
Plugin openstreetbugs Version: 19060
Plugin PicLayer Version: 19062
Plugin tageditor Version: 18955
Plugin validator Version: 19224
Plugin livegps Version: 19056
Plugin tagging-preset-tester Version: 19222
Plugin measurement Version: 19058
Plugin multipoly Version: 19138
Plugin walkingpapers Version: 19074
Plugin colorscheme Version: 18413
Plugin wmsplugin Version: 18953
Plugin editgpx Version: 19052
Plugin openvisible Version: 17536
Plugin DirectUpload Version: 19082
Plugin waydownloader Version: 19047
Plugin surveyor Version: 19211

java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/gpx/SingleSegmentGpxTrack
	at livegps.LiveGpsLayer.<init>(LiveGpsLayer.java:51)
	at livegps.LiveGpsPlugin.enableTracking(LiveGpsPlugin.java:193)
	at livegps.LiveGpsPlugin$CaptureAction.actionPerformed(LiveGpsPlugin.java:64)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:374)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1688)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1732)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6106)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
	at java.awt.Component.processEvent(Component.java:5871)
	at java.awt.Container.processEvent(Container.java:2105)
	at java.awt.Component.dispatchEventImpl(Component.java:4467)
	at java.awt.Container.dispatchEventImpl(Container.java:2163)
	at java.awt.Component.dispatchEvent(Component.java:4293)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
	at java.awt.Container.dispatchEventImpl(Container.java:2149)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4293)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.gpx.SingleSegmentGpxTrack
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
	... 31 more

Attachments (0)

Change History (15)

comment:1 Changed 10 years ago by jttt

Resolution: worksforme
Status: newclosed

Update also livegps plugin to latest. If it still doesn't work with latest livegps plugin then please reopen the ticket.

comment:2 Changed 10 years ago by anonymous

Resolution: worksforme
Status: closedreopened

Used the UPDATE function of the plugins 3 times. Always downloading all
plugins and restarting but staying at the same version (see trace below)

I updated the plugins yesterday too (at startup, then restarted),
but versions are different to todays download.

Plugin keeps crashing.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-02 02:31:29
Last Changed Author: bastiK
Revision: 3067
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-02 00:12:01 +0100 (Tue, 02 Mar 2010)
Last Changed Rev: 3067

Memory Usage: 46 MB / 493 MB (21 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK Server VM
Operating system: Linux

Dataset consistency test:
No problems found

Plugins: DirectUpload,PicLayer,colorscheme,editgpx,livegps,measurement,multipoly,openstreetbugs,openvisible,plastic_laf,surveyor,tageditor,tagging-preset-tester,validator,walkingpapers,waydownloader,wmsplugin
Plugin plastic_laf Version: 19469
Plugin openstreetbugs Version: 19463
Plugin PicLayer Version: 20217
Plugin tageditor Version: 20197
Plugin validator Version: 20155
Plugin livegps Version: 19680
Plugin tagging-preset-tester Version: 19481
Plugin measurement Version: 19681
Plugin multipoly Version: 19456
Plugin walkingpapers Version: 19487
Plugin colorscheme Version: 19426
Plugin wmsplugin Version: 19992
Plugin editgpx Version: 19683
Plugin openvisible Version: 20067
Plugin DirectUpload Version: 19700
Plugin waydownloader Version: 19489
Plugin surveyor Version: 19681

java.lang.NoClassDefFoundError: org/openstreetmap/josm/data/gpx/SingleSegmentGpxTrack

at livegps.LiveGpsLayer.<init>(LiveGpsLayer.java:51)
at livegps.LiveGpsPlugin.enableTracking(LiveGpsPlugin.java:193)
at livegps.LiveGpsPlugin$CaptureAction.actionPerformed(LiveGpsPlugin.java:64)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
at javax.swing.AbstractButton.doClick(AbstractButton.java:374)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1688)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1732)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
at java.awt.Component.processMouseEvent(Component.java:6106)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3276)
at java.awt.Component.processEvent(Component.java:5871)
at java.awt.Container.processEvent(Container.java:2105)
at java.awt.Component.dispatchEventImpl(Component.java:4467)
at java.awt.Container.dispatchEventImpl(Container.java:2163)
at java.awt.Component.dispatchEvent(Component.java:4293)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4461)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4125)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4055)
at java.awt.Container.dispatchEventImpl(Container.java:2149)
at java.awt.Window.dispatchEventImpl(Window.java:2478)
at java.awt.Component.dispatchEvent(Component.java:4293)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:604)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

Caused by: java.lang.ClassNotFoundException: org.openstreetmap.josm.data.gpx.SingleSegmentGpxTrack

at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
... 31 more

comment:3 Changed 10 years ago by jttt

Owner: changed from team to stoecker
Status: reopenednew

Dirk, can you please have a look at this? The SingleSegmentGpxTrack class is in svn but not in josm-latest.jar. The class is used only by livegps plugin but anyway it should be included in snapshot.

comment:4 Changed 10 years ago by stoecker

The server does not compile code which is unused. When the class is only used by LiveGPS, then why don't we move it there?

comment:5 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

Fixed in [o20264]

comment:6 Changed 10 years ago by jttt

Dirk, can you please update build script for josm-custom, so that it also skip unused classes? I run hudson on my laptop to prevent errors like this, but having different build scripts makes it difficult.

comment:7 Changed 10 years ago by anonymous

Ticket #4658 has been marked as a duplicate of this ticket.

comment:8 Changed 10 years ago by jttt

btw, the SingleSegmentGpxTrack was in josm because it was used by three plugins

comment:9 Changed 10 years ago by stoecker

I don't know if an "ant" build also can do this.

comment:10 Changed 10 years ago by jttt

(In [3091]) Added ProGuard tool (see #4640)

comment:11 Changed 10 years ago by jttt

I've added dist-optimized task to build script in svn that should also remove unused classes.

comment:12 Changed 10 years ago by anonymous

Resolution: fixed
Status: closedreopened

Now I get a NullPointerException:

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-03-07 02:31:42
Last Changed Author: jttt
Revision: 3091
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-03-06 17:27:45 +0100 (Sat, 06 Mar 2010)
Last Changed Rev: 3091

Memory Usage: 53 MB / 493 MB (6 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK Server VM
Operating system: Linux

Dataset consistency test:
No problems found

Plugins: DirectUpload,PicLayer,colorscheme,editgpx,livegps,measurement,multipoly,openstreetbugs,openvisible,plastic_laf,public_transport,surveyor,tageditor,tagging-preset-tester,validator,walkingpapers,waydownloader,wmsplugin
Plugin plastic_laf Version: 19469
Plugin openstreetbugs Version: 19463
Plugin PicLayer Version: 20217
Plugin tageditor Version: 20197
Plugin validator Version: 20155
Plugin livegps Version: 19680
Plugin measurement Version: 19681
Plugin multipoly Version: 19456
Plugin walkingpapers Version: 19487
Plugin colorscheme Version: 19426
Plugin wmsplugin Version: 19992
Plugin editgpx Version: 19683
Plugin openvisible Version: 20067
Plugin public_transport Version: 20072
Plugin DirectUpload Version: 19700
Plugin waydownloader Version: 19489
Plugin surveyor Version: 19681

java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.GpxLayer.paint(GpxLayer.java:613)
at livegps.LiveGpsLayer.paint(LiveGpsLayer.java:104)
at org.openstreetmap.josm.gui.MapView.paint(MapView.java:475)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1042)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JLayeredPane.paint(JLayeredPane.java:581)
at javax.swing.JComponent.paintChildren(JComponent.java:875)
at javax.swing.JComponent.paint(JComponent.java:1047)
at javax.swing.JComponent.paintToOffscreen(JComponent.java:5147)
at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
at javax.swing.JComponent._paintImmediately(JComponent.java:5095)
at javax.swing.JComponent.paintImmediately(JComponent.java:4905)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

comment:13 Changed 10 years ago by meppen7

See also track 4672

comment:14 Changed 10 years ago by stoecker

Resolution: duplicate
Status: reopenedclosed

comment:15 Changed 10 years ago by stoecker

Closed as duplicate of #4672.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain stoecker.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.