Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4629 closed defect (duplicate)

josm stores password in 644 file

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Password is stored in plaintext, in world-readable file. josm 3037.

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by bastiK

Resolution: invalid
Status: newclosed

Yes and this is clearly stated when you are about to save it. (You are not forced to do so.) What do you suggest it should do instead?

Btw. there is OAuth, now. It saves the authorization token in plain file, as well. But at least the potentially evil housemate can no longer steal your account, since you can revoke the token.

comment:2 Changed 11 years ago by jstein

Resolution: invalid
Status: closedreopened

comment:3 Changed 11 years ago by jstein

Resolution: duplicate
Status: reopenedclosed

comment:4 Changed 11 years ago by jstein

Closed as duplicate of #4667.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.