Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4624 closed defect (fixed)

Relations not rendered right away

Reported by: bastiK Owned by: team
Priority: critical Milestone:
Component: Core Version:
Keywords: mappaint Cc:

Description

Create a new Layer and create a new multipolygon relation (with area tags on the relation only.)

-> It is not rendered as an area.

Do some stuff like save and reopen or duplicate layer or just add a single tag. -> It is rendered as an area.

Attachments (1)

bug-multipolygon.osm (1.5 KB) - added by bastiK 11 years ago.
create a relation like this. Note that the bug is not visible if you just open the file.

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by bastiK

Attachment: bug-multipolygon.osm added

create a relation like this. Note that the bug is not visible if you just open the file.

comment:1 Changed 11 years ago by jttt

I can't reproduce this (tested with sun java)

comment:2 Changed 11 years ago by bastiK

It's quite easy to miss this, if you do not follow the exact steps.

Another way to see it: Open the file and make a duplicate of the relation. Then delete the old relation. Then the multipolygon is not rendered. If you move a node it is ok.

comment:3 Changed 11 years ago by jttt

It works for me. Is the multipolygon correctly rendered after you add any point to the dataset or do you have to do some modification on the multipolygon itself?

comment:4 Changed 11 years ago by bastiK

No effect:

  • add a node
  • add a node to a way of the multipolygon
  • move that node around

rendering starts correctly:

  • move a node that was there in the first place
  • add an arbitrary tag to the relation

once it is rendered correctly there is no way to expose the bug again

Build-Date: 2010-02-27 16:21:30		
Revision: 3054
Is-Local-Build: true

Memory Usage: 34 MB / 297 MB (7 MB allocated, but free)
Java version: 1.6.0_15, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux

Dataset consistency test:
No problems found

and

Build-Date: 2010-02-26 20:06:14		
Revision: 3045
Is-Local-Build: true

Memory Usage: 14 MB / 297 MB (4 MB allocated, but free)
Java version: 1.6.0_0, Sun Microsystems Inc., OpenJDK Client VM
Operating system: Linux

I can investigate myself, but not today :)

comment:5 Changed 11 years ago by bastiK

Ticket #4696 has been marked as a duplicate of this ticket.

comment:6 Changed 11 years ago by stoecker

Ticket #4702 has been marked as a duplicate of this ticket.

comment:7 Changed 11 years ago by stoecker

Priority: majorcritical
Summary: Multipolygon relation is not rendered right awayRelations not rendered right away

comment:8 in reply to:  3 Changed 11 years ago by Gubaer

Replying to jttt:

It works for me. Is the multipolygon correctly rendered after you add any point to the dataset or do you have to do some modification on the multipolygon itself?

#4696 includes a small test case and "test script" which reliably reproduces the defect.

comment:9 Changed 11 years ago by jttt

Now it looks clear, bbox for relations is cached and it's not updated when node is added to the relation. I'll fix it when I get home.

comment:10 Changed 11 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3107]) Fix #4624 Relations not rendered right away

comment:11 Changed 11 years ago by skyper

Ticket #4623 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.