Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4572 closed defect (fixed)

after update data - way contains deleted member

Reported by: bastiK Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: relation update r-2010-01-blocker Cc: skyper

Description

After File > update data, the way contains a deleted node.

data consistency test:
[DELETED REFERENCED] {Way id=50672497 version=1 V nodes=[{Node id=645270597 version=1 V lat=52.3181898,lon=14.1661305}, {Node id=645240847 version=1 VD lat=52.3154516,lon=14.1667404}, {Node id=645270591 version=1 MV lat=52.31393982080329,lon=14.168653708581134}]} refers to deleted primitive {Node id=645240847 version=1 VD lat=52.3154516,lon=14.1667404}

Attachments (1)

way with deleleted node.png (37.7 KB) - added by bastiK 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by bastiK

Attachment: way with deleleted node.png added

comment:1 Changed 10 years ago by bastiK

(I deleted the node in another instance.)

comment:2 Changed 10 years ago by mjulius

Ticket #4571 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by skyper

Keywords: update relation added
Priority: normalblocker

comment:4 Changed 10 years ago by skyper

Cc: skyper added

comment:5 Changed 10 years ago by skyper

Keywords: update relationrelation update

comment:6 Changed 10 years ago by skyper

Keywords: r-2010-01-blocker added

comment:7 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3033]) Fix #4572 after update data - way contains deleted member

comment:8 Changed 10 years ago by jttt

Note that there will still be referenced deleted primitives (see #4467). But at least there will be conflict for it and after resolving conflicts, the dataset should be without referenced deleted primitives.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.