Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4555 closed defect (duplicate)

Errors on start up

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Ran 3009, plugins updated, then JOSM errored and stalls.
  2. Have to close the console window to exit the program.
  3. Tried to run the program again only to have it produce the same error.
  4. No editing today, no joy.

What is the expected result?
Should have just updated the plugins and started.

What happens instead?
The major error occurs, the program shows me the error and stalls at "Creating main GUI" with the little cylon eye sliding back and forth.

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-02-18 02:31:18
Last Changed Author: bastiK
Revision: 3009
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-17 23:48:31 +0100 (Wed, 17 Feb 2010)
Last Changed Rev: 3009

Memory Usage: 15 MB / 989 MB (4 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows Vista


Plugins: wmsplugin,remotecontrol,buildings_tools,validator,routing

java.lang.NullPointerException
	at org.openstreetmap.josm.io.MirroredInputStream.getZipEntry(MirroredInputStream.java:102)
	at org.openstreetmap.josm.gui.tagging.TaggingPreset.readFromPreferences(TaggingPreset.java:648)
	at org.openstreetmap.josm.gui.preferences.TaggingPresetPreference.initialize(TaggingPresetPreference.java:84)
	at org.openstreetmap.josm.Main.<init>(Main.java:214)
	at org.openstreetmap.josm.gui.MainApplication.<init>(MainApplication.java:49)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java%

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by jttt

Resolution: duplicate
Status: newclosed

comment:2 Changed 12 years ago by anonymous

Closed as duplicate of #4551.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.