Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4528 closed defect (fixed)

Search for colon-containing keys broken

Reported by: Ldp Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: r-2010-01-blocker Cc:

Description

Searching for colon-containing keys was broken in the past few days. Searching for one, for instance "a:b"=1 brings up a popup:

Unexpected token: <number>

Attachments (0)

Change History (9)

comment:1 Changed 10 years ago by Ldp

Also broken:

nodes:100-2000

comment:2 Changed 10 years ago by avarab@…

Keywords: r-2010-01-blocker added
Priority: normalmajor
Version: latest

Also broken: Tokens separated by =:

ref=1234

Adding this as a release blocker.

comment:3 Changed 10 years ago by Gubaer

Looks like a regression, possibly introduced in r2973?

comment:4 Changed 10 years ago by jttt

Yes, it was introduced in r2973. I'll fix it.

comment:5 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2993]) Fix #4528 Search for colon-containing keys broken

comment:6 in reply to:  5 Changed 10 years ago by avarab@…

Resolution: fixed
Status: closedreopened

Replying to jttt:

(In [2993]) Fix #4528 Search for colon-containing keys broken

This fix broke searches like:

type:node

and:

foo$:bar$

When using regex search

comment:7 Changed 10 years ago by jttt

Resolution: fixed
Status: reopenedclosed

(In [2995]) Fix #4528: Search for colon-containing keys broken

comment:8 Changed 10 years ago by jttt

Btw ^foo$:^bar$ is no longer necessary, foo=bar does the same thing

comment:9 in reply to:  8 Changed 10 years ago by avarab@…

Replying to jttt:

Btw ^foo$:^bar$ is no longer necessary, foo=bar does the same thing

I just added it as a testcase showing that regex search was also broken, but thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.