Modify

Opened 10 years ago

Closed 9 years ago

#4487 closed defect (fixed)

Error handling in josm load XML routine

Reported by: cetest Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: import xml error parse Cc:

Description

The error handling in JOSM XML import can be improved:
-include line and column number for every import error !! Important.
-create more to the point error messages; currently these are plain nonsense 80%

make sure any error condition can be terminated using the mouse. Too often
a parse error gives a error message box that cannot be clicked until the import progress box
has finished, and this will never finish because the import is halted until the error box is clicked/confirmed. A classic bug.

This happens with memory errors also.
It might be windows related.

Attachments (2)

police1.xml (5.1 KB) - added by cetest 10 years ago.
xml file leading to import problems
rest.zip (25.7 KB) - added by cetest 10 years ago.
no need to add the nodes anymore ,:))

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by cetest

Keywords: r-2010-01-blocker added
Summary: rror handling in josm load XML routineError handling in josm load XML routine

r-2010-01-blocker

This window lock-out problem happens with other errors too, such as out of memory
error. The lock-out happens not always... about 60%
The only way to terminate JOSM then is to use task manager.

This bug might be widows related. Not a reason to ignore though ;<))

comment:2 Changed 10 years ago by Gubaer

I don't think this is a r-2010-01-blocker. I agree that "... error handling in JOSM XML import can be improved ..." but I don't think this ticket is a show stopper for the next release.

I suppose that you run into trouble when you tried to import the Radio/TV studios in Haiti. You probably tried to load OSM files you created yourself with scripts. I'd be interested in them as test cases. Could you post a couple of these badly structure OSM files such that we can improve JOSMs robustness?

Changed 10 years ago by cetest

Attachment: police1.xml added

xml file leading to import problems

comment:3 Changed 10 years ago by cetest

wanted to add a few other files, but the stupid spam filter took the file for spam, due to too many external links, yeah there are , but no spam.
Then some addition was presented to me, but it did not result in allowance of the attachment.
Should I file a ticket for "trac" now ???
Send me your email address and i'll forward the rest.

Gert

comment:4 Changed 10 years ago by stoecker

zip the file and upload it again.

Changed 10 years ago by cetest

Attachment: rest.zip added

no need to add the nodes anymore ,:))

comment:5 Changed 10 years ago by Gubaer

Keywords: r-2010-01-blocker removed

comment:6 Changed 9 years ago by jttt

(In [3226]) Show line number in error message when loading of osm file fails. See #4487

comment:7 Changed 9 years ago by stoecker

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.