Modify

Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#4468 closed defect (fixed)

Status -> OutOfMemory after copying layer

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: OutOfMemory copy layer Cc:

Description

After #4441 happend I tried to get the status but ran OutOfMemory.
It only happens using a copied layer and is reproducibale.

  1. open file.
  2. copy layer, do not save it but contine to work with copy.
  3. update data -> #4441
  4. close ERROR-message
  5. try to get status -> OutOfMemory

I did a heap dump. Is there some save place to upload it to ?

please use attached osm file from #4441

Attachments (0)

Change History (3)

comment:2 Changed 10 years ago by skyper

@jttt

Hi, did you get my mail today. I am not sure if it was sent.
Cheers

comment:3 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2958]) Fix #4468 Status -> OutOfMemory after copying layer

comment:4 Changed 10 years ago by jttt

I got the mail, thanks. The out of memory happend in DatasetConsistencyTest, there were so many errors, that the log occupied all memory. I didn't fix the cause (consistency errors), I've only limited the number of errors shown. Fixing the errors is #4409.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.