Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4444 closed defect (fixed)

AssertionError when double-clicking on relation info

Reported by: wiml@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Select an area that's part of a relation (eg way 40494482)
  2. Have the "properties" pane open
  3. Scroll down to "Member of" and doubleclick on the line of text in this section ("multipolygon[8] ("Cospmopolis")")
  4. Exception window appears!
Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-01-28 02:32:17
Last Changed Author: mjulius
Revision: 2899
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-01-27 22:21:17 +0100 (Wed, 27 Jan 2010)
Last Changed Rev: 2899

Memory Usage: 1018 MB / 1018 MB (304 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found


Plugins: PicLayer,lakewalker,slippymap,validator,wmsplugin
Plugin wmsplugin Version: 19626
Plugin PicLayer Version: 19467
Plugin validator Version: 19616
Plugin slippymap Version: 19521
Plugin lakewalker Version: 19624

java.lang.AssertionError
	at org.openstreetmap.josm.gui.dialogs.RelationListDialog.selectRelation(RelationListDialog.java:225)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.membershipEdit(PropertiesDialog.java:320)
	at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog$DblClickWatch.mouseClicked(PropertiesDialog.java:129)
	at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:253)
	at java.awt.Component.processMouseEvent(Component.java:6351)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
	at java.awt.Component.processEvent(Component.java:6113)
	at java.awt.Container.processEvent(Container.java:2085)
	at java.awt.Component.dispatchEventImpl(Component.java:4714)
	at java.awt.Container.dispatchEventImpl(Container.java:2143)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4291)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
	at java.awt.Container.dispatchEventImpl(Container.java:2129)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by mjulius

Owner: changed from team to wiml@…
Status: newneedinfo

I can not reproduce this here. Do you still see this issue and if so, can you provide more detailed instructions how to reproduce? It would be good to have each step from starting JOSM to the error including the exact bounding box to download.

comment:2 in reply to:  1 Changed 11 years ago by wiml@…

Owner: changed from wiml@… to team
Status: needinfonew

Replying to mjulius:

It still happens to me reliably (using r2899 or r2906, which is currently 'latest'). Step by step:

  • launch josm, e.g.: java -jar ~/josm-latest.jar
  • download the area, eg: http://api.openstreetmap.org/api/0.6/map?bbox=-123.85574340820312,46.94182449351122,-123.74038696289062,46.97931541867999
  • zoom in a bit on the resulting map to make it easier to select things.
  • Select one of the multipolygon areas: Any of the city boundaries seem to provoke the error equally well. Cosmopolis is towards the right, below the bend in the river.
  • Resize the "properties" pane slightly so that you can see the relations at the end of the list.
  • double-click on the relation line, and boom.

I am running on a mac (osx 10.6.2) though I doubt that is significant here.

comment:3 Changed 11 years ago by mjulius

Resolution: fixed
Status: newclosed

Did you have the relation list hidden when you tried that?

Anyway, this seems to have been fixed in r2914.

comment:4 in reply to:  3 Changed 11 years ago by anonymous

Can no longer reproduce the problem in r2920, excellent.

(And opening the relations window does keep the exception from happening in r2906, so that mystery's solved)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.