Modify

Opened 10 years ago

Closed 10 years ago

#4432 closed defect (fixed)

NullPointerException in history panel

Reported by: wiml@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. click on way 8072147
  2. dblclick on the way in the "History" pane in the sidebar
  3. click on a changeset entry in the panel that appears
  4. exception window comes up :(

Please provide any additional information below. Attach a screenshot if
possible.

currently running josm-latest on mac osx 10.6.2.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-01-26 02:32:20
Last Changed Author: bastiK
Revision: 2894
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-01-25 23:05:57 +0100 (Mon, 25 Jan 2010)
Last Changed Rev: 2894

Memory Usage: 81 MB / 81 MB (1 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found


Plugins: PicLayer,lakewalker,slippymap,validator,wmsplugin
Plugin wmsplugin Version: 19626
Plugin PicLayer Version: 19467
Plugin validator Version: 19616
Plugin slippymap Version: 19521
Plugin lakewalker Version: 19624

java.lang.NullPointerException
	at org.openstreetmap.josm.gui.history.VersionTableCellRenderer.renderVersionFromHistory(VersionTableCellRenderer.java:137)
	at org.openstreetmap.josm.gui.history.VersionTableCellRenderer.getTableCellRendererComponent(VersionTableCellRenderer.java:153)
	at javax.swing.JTable$AccessibleJTable.getAccessibleChild(JTable.java:7032)
	at javax.swing.JTable$AccessibleJTable.getAccessibleAt(JTable.java:7419)
	at javax.swing.JTable$AccessibleJTable.valueChanged(JTable.java:6934)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:147)
	at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:194)
	at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:388)
	at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:398)
	at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:442)
	at javax.swing.JTable.changeSelectionModel(JTable.java:2351)
	at javax.swing.JTable.changeSelection(JTable.java:2420)
	at javax.swing.plaf.basic.BasicTableUI$Handler.adjustSelection(BasicTableUI.java:1085)
	at javax.swing.plaf.basic.BasicTableUI$Handler.mousePressed(BasicTableUI.java:1008)
	at javax.swing.plaf.basic.BasicTableUI$MouseInputHandler.mousePressed(BasicTableUI.java:768)
	at com.apple.laf.AquaTableUI$MouseInputHandler.mousePressed(AquaTableUI.java:73)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:263)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:262)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:262)
	at java.awt.Component.processMouseEvent(Component.java:6345)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
	at java.awt.Component.processEvent(Component.java:6113)
	at java.awt.Container.processEvent(Container.java:2085)
	at java.awt.Component.dispatchEventImpl(Component.java:4714)
	at java.awt.Container.dispatchEventImpl(Container.java:2143)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4618)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4279)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4212)
	at java.awt.Container.dispatchEventImpl(Container.java:2129)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4544)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:635)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by mjulius

I can not reproduce this in r2925 under WinXP.

comment:2 Changed 10 years ago by mjulius

Ticket #4452 has been marked as a duplicate of this ticket.

comment:3 Changed 10 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2959]) fixed #4432: NullPointerException in history panel

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.