Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4403 closed defect (duplicate)

JOSM silently resolves conflicts by destroying data

Reported by: Nakor Owned by: team
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Upload attached file, you will get a conflict that the deleted node still exists in the DB.
Choose "Prepare conflict resolution"
The resolution window comes up empty
Try to upload again (DO NOT actually do it)

JOSM simply deletes the node from the two ways it was in, effectively destroying data without letting the user now.

Attachments (1)

issue.osm (447 bytes) - added by Nakor 10 years ago.

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by Nakor

Attachment: issue.osm added

comment:1 Changed 10 years ago by Nakor

Version: latest

Still current in

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-02-02 02:31:27
Last Changed Author: jttt
Revision: 2920
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-01 21:56:31 +0100 (Mon, 01 Feb 2010)
Last Changed Rev: 2920

comment:2 Changed 10 years ago by mjulius

Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by mjulius

Closed as duplicate of #4467.

comment:4 Changed 10 years ago by bastiK

Ticket #4402 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.