Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4330 closed defect (fixed)

java.lang.ArrayIndexOutOfBoundsException: 6 >= 6

Reported by: meppen7 Owned by: team
Priority: major Milestone:
Component: Core Version: latest
Keywords: Cc: florian@…

Description

Happens while doing some corrections. Did several corrections and uploads before without error message.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-01-09 02:31:38
Last Changed Author: mjulius
Revision: 2784
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-01-09 00:50:20 +0100 (Sat, 09 Jan 2010)
Last Changed Rev: 2784

Memory Usage: 54 MB / 1016 MB (19 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found

Plugins: AddrInterpolation,buildings_tools,editgpx,ghost,graphview,livegps,mappinonosm,measurement,multipoly,openstreetbugs,openvisible,remotecontrol,routing,surveyor,tageditor,terracer,validator,walkingpapers,waydownloader,wms-turbo-challenge2,wmsplugin
Plugin AddrInterpolation Version: 18874
Plugin buildings_tools Version: 28
Plugin editgpx Version: 19052
Plugin ghost Version: 1
Plugin graphview Version: 19292
Plugin livegps Version: 19056
Plugin mappinonosm Version: 4
Plugin measurement Version: 19058
Plugin multipoly Version: 19138
Plugin openstreetbugs Version: 19283
Plugin openvisible Version: 19004
Plugin remotecontrol Version: 19298
Plugin routing Version: 19300
Plugin tageditor Version: 18976
Plugin terracer Version: 19234
Plugin validator Version: 19304
Plugin walkingpapers Version: 19074
Plugin waydownloader Version: 19047
Plugin wms-turbo-challenge2 Version: 15358
Plugin wmsplugin Version: 19306
Plugin surveyor Version: 19211

java.lang.ArrayIndexOutOfBoundsException: 6 >= 6

at java.util.Vector.elementAt(Unknown Source)
at javax.swing.table.DefaultTableModel.getValueAt(Unknown Source)
at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.selectionChanged(PropertiesDialog.java:711)
at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.updateSelection(PropertiesDialog.java:824)
at org.openstreetmap.josm.gui.dialogs.properties.PropertiesDialog.processDatasetEvent(PropertiesDialog.java:836)
at org.openstreetmap.josm.data.osm.event.DataSetListenerAdapter.tagsChanged(DataSetListenerAdapter.java:43)
at org.openstreetmap.josm.data.osm.event.TagsChangedEvent.fire(TagsChangedEvent.java:24)
at org.openstreetmap.josm.data.osm.event.DatasetEventManager.fireConsolidatedEvents(DatasetEventManager.java:117)
at org.openstreetmap.josm.data.osm.event.DatasetEventManager.access$300(DatasetEventManager.java:27)
at org.openstreetmap.josm.data.osm.event.DatasetEventManager$1.run(DatasetEventManager.java:161)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (2)

josm_bug4330.txt (2.5 KB) - added by holbi@… 11 years ago.
error output
josm_bug4330.zip (1.7 MB) - added by holbi@… 11 years ago.
Two .osm I've worked on when the crash occured

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by stoecker

Can you probably provide a testcase (e.g. your osm file where this happens) together with a description how to get this error?

comment:2 Changed 11 years ago by meppen7

Sorry, but I can not fullfill this wish.I thought the IArrayIndexOutOfBoundsException would be a clear informatin for our fantastic developers.
I closed JOSM and started an new session. Since then I did a lot of corretions and uploads without any error message. So the bug can not be very critical.
In case this error comes up again, I will grant more observation.

meppenz

comment:3 Changed 11 years ago by meppen7

Further Comment:
As far as I remember after closing the message eror box, I was able to contiue working with JOSM. But I decided to continue with a clean system, so I restarted JOSM.

Changed 11 years ago by holbi@…

Attachment: josm_bug4330.txt added

error output

comment:4 Changed 11 years ago by hwb <holbi@…>

I have the same problem.
When working on larger datasets (whole administrative district (Landkreis) downloaded in several requests for editing Boundaries) after some time JOSM throws an error when selecting an Item. This firstly occured on version 2813 so I've updated to 2864 which has the same problem. When the error is ignored it appears again on every selection action. Uploading the edits is still possible, but in my case there was no way to continue the work without restarting JOSM.

hwb

comment:5 Changed 11 years ago by hwb <holbi@…>

And the same again, different version of JOSM (2879) and different area. First downloaded and edited a large area, upload, download a smaller area, again some edits and crash.

Changed 11 years ago by holbi@…

Attachment: josm_bug4330.zip added

Two .osm I've worked on when the crash occured

comment:6 in reply to:  5 Changed 11 years ago by hwb <holbi@…>

Replying to holbi@…:
It also happens with only few data loaded. I've worked with osm-tmc.anders-hamburg.de and remote control for JOSM, after having edited 5 boundary relations and a few points it crashed again. Error message and .osm on request.

comment:7 Changed 11 years ago by grossing

Cc: florian@… added

I'm sometimes working with very large areas (sometimes over 400000 nodes) and i didn't got this error yet.
As i can see in the logs above, all of them who see this error working with remotecontrol. I don' have this plugin installed, perhaps could this help.
BTW: normally i use one of the newest josm-latest

comment:8 Changed 11 years ago by stoecker

Resolution: fixed
Status: newclosed

In r2912.

comment:9 Changed 11 years ago by jttt

It's possible this was caused by two threads processing PropertiesDialog.selectionChanged in the same time, in that case it was fixed by r2912. If not then please reopen.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.