Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4324 closed defect (duplicate)

New ways not displayed

Reported by: stoecker Owned by: jttt
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: way mappaint Cc: malenki

Description

Under rare conditions new ways are not displayed in JOSM. Zooming a bit in and out usually shows them again. I was not yet able to make it reproducable. Probably an issue with wrong handling in QuadBuckets.

Attachments (6)

disappearing_ways.osm (17.2 KB) - added by Ldp 10 years ago.
Example of this happening for me
gkrellShoot_2010-01-24_134508_new_way_complete.png (191.8 KB) - added by malenki 10 years ago.
new_way_complete
gkrellShoot_2010-01-24_135926_new_way_complete.png (191.0 KB) - added by malenki 10 years ago.
new_way_complete
gkrellShoot_2010-01-24_135936_way_splitted_disappeared.png (187.9 KB) - added by malenki 10 years ago.
way_splitted_disappeared
gkrellShoot_2010-01-24_135950_new_way_still_exists.png (206.3 KB) - added by malenki 10 years ago.
way_still_exists
nil_broken.osm (593.4 KB) - added by malenki 10 years ago.

Download all attachments as: .zip

Change History (32)

comment:1 Changed 10 years ago by Gubaer

This happens very often while mapping. I'll collect sample bounding boxes with sample objects to reproduce and I'll post them here.

comment:2 Changed 10 years ago by vsandre

Keywords: way mappaint added
Priority: normalcritical
Version: latest

I have downloaded a small area and than all members of a containing route relation. And now the problem appears, no ways were shown. Afterwards I saved and deleted the data layer, with the aim to reproduce the bug, but all works fine. Also the saved file looks fine.

This bug is very annoying and could leads into wrong edits.

comment:3 Changed 10 years ago by vsandre

BTW selecting the route relation shows all ways.

Changed 10 years ago by Ldp

Attachment: disappearing_ways.osm added

Example of this happening for me

comment:4 Changed 10 years ago by Ldp

Load my example file, and drag one of the nodes. The way disappears, while the nodes are still painted. Zoom out pretty far to get the way painted again.

comment:5 Changed 10 years ago by Ldp

I went back to r2000 and worked my way back in steps, and I found my use case (see disappearing_ways.osm) was introduced in r2450 ('Added parameter Bounds to MapView, draw only currently visible primitives in MapPaintVisititor').

I had personally classified this (disappearing ways) as a Heisenbug, because I could never reproduce it before.

comment:6 Changed 10 years ago by malenki

Cc: malenki added

This bug could be related to #4111. Trying to reproduce it with r2864 did not result in a disappearing way but in a way who couldn't be selected anymore. Nodes can be selected, dragged around and used to continue the way. The way itself remains unselectable.

comment:7 Changed 10 years ago by jttt

Owner: changed from team to jttt

I can confirm that with disappearing_ways.osm. I'm working on a fix.

comment:8 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2868]) Fixed #4324 New ways not displayed

comment:9 Changed 10 years ago by malenki

Priority: criticalmajor

In r2887 I experience a not straightforward reproducible error in wireframe view.

It appeared as I worked on Nile with Lakewalker. Sometimes newly created ways weren't displayed at all (only the nodes), sometimes parts of the way vanished after splitting. See attachments

Changed 10 years ago by malenki

new_way_complete

Changed 10 years ago by malenki

new_way_complete

Changed 10 years ago by malenki

way_splitted_disappeared

Changed 10 years ago by malenki

way_still_exists

comment:10 Changed 10 years ago by malenki

Resolution: fixed
Status: closedreopened

PS: I forgot to overwrite "gkrellShoot_2010-01-24_134508_new_way_complete.png" - can be deleted (or just disregard it)

comment:11 Changed 10 years ago by malenki

Priority: majorblocker

Changed to blocker since though the ways are diplayed in mappaint they don't exist. Validator sais there are thousands of empty nodes. Ways which weren't changed but happened to be displayed also disappeared leaving only the nodes behind. See attachment. Some hours of work wasted :€

Changed 10 years ago by malenki

Attachment: nil_broken.osm added

comment:12 Changed 10 years ago by malenki

For the attachment nil_broken.osm: If it can be repaired easily it would nice if it would be uploaded (without the deletions at HammerHeads ways and nodes). Would hate if I really had wasted so much time...

comment:13 Changed 10 years ago by jttt

What Dataset consistency test says? (right click on osm layer)

comment:14 Changed 10 years ago by malenki

Hrm. This i forgot to perform as I reported the bug. The Joms instance where this happened is long since closed. To the attached file the consistency test sais:

{Way id=5229400 version=6 V nodes=[]} not found using Dataset.searchWays()
Way {Way id=5229400 version=6 V nodes=[]} has zero nodes

comment:15 Changed 10 years ago by jttt

Hm, next time this kind of bug happens make also heap dump (see #4057 for details).

comment:16 Changed 10 years ago by jttt

Do you remember when the problems started? From the beginning, after data updated or some other event?

Also do I understand it right that the ways were displayed in mappaint mode, but not in wireframe mode?

comment:17 Changed 10 years ago by jttt

It looks like #4057 strikes again. And again lakewalker was used.

comment:18 in reply to:  17 ; Changed 10 years ago by anonymous

Replying to jttt:

It looks like #4057 strikes again. And again lakewalker was used.

If you think this is true, it's not true in every case. I have not used lakewalker, and don't even have it loaded, and yet (as can be seen in disappearing_ways.osm) I also have intermittent issues. Split in 2 tickets?

comment:19 in reply to:  18 ; Changed 10 years ago by Ldp

Replying to anonymous:

Replying to jttt:

It looks like #4057 strikes again. And again lakewalker was used.

If you think this is true, it's not true in every case. I have not used lakewalker, and don't even have it loaded, and yet (as can be seen in disappearing_ways.osm) I also have intermittent issues. Split in 2 tickets?

Anonymous replies sometimes considered harmful. This was me.

comment:20 Changed 10 years ago by jttt

The original issue is fixed in r2868 (the one with disappearing_ways.osm), the problem reported by malenki is different (and yes, it should have been in separated ticket).

comment:21 in reply to:  16 Changed 10 years ago by malenki

Replying to jttt:

Do you remember when the problems started? From the beginning,

no, just some time after I started editing

Also do I understand it right that the ways were displayed in mappaint mode, but not in wireframe mode?

yes

comment:22 in reply to:  19 Changed 10 years ago by malenki

Replying to Ldp:

Replying to anonymous:

Replying to jttt:

It looks like #4057 strikes again. And again lakewalker was used.

yes (though I didn't mention it explicitly)

If you think this is true, it's not true in every case. I have not used lakewalker, and don't even have it loaded, and yet (as can be seen in disappearing_ways.osm)

The attachment contains broken data so it is not relevant imo which plugins you at your josm are active.

comment:23 in reply to:  20 Changed 10 years ago by malenki

Replying to jttt:

The original issue is fixed in r2868 (the one with disappearing_ways.osm) [was created, you mean?]

the problem reported by malenki is different

How should I have known?

(and yes, it should have been in separated ticket).

Next time one has to tell me before reopening/adding a a ticket. One time I was "scolded" not having reopened a ticket, now I am having done so. Sums up to zero :)

comment:24 Changed 10 years ago by stoecker

Only use existing tickets when you are sure the issue is the same. Use a new one otherwise. You get blamed correctly when you open a new ticket and the same issue has been reported shortly before in another one. Ignore any blaming when the previous ticket is older or could not be found with an easy search.

It is not the task of a user to maintain the tickets or guess whether they really represent equal topics, but he should also not increase developers load by obvious duplicates.

comment:25 Changed 10 years ago by jttt

Resolution: duplicate
Status: reopenedclosed

I might have fixed the bug, see #4057 for details.

comment:26 Changed 10 years ago by anonymous

Closed as duplicate of #4057.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jttt.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.