Modify

Opened 11 years ago

Closed 11 years ago

#4321 closed defect (invalid)

Validator: crossing ways check broken

Reported by: Cobra Owned by: team
Priority: major Milestone:
Component: Core validator Version: latest
Keywords: crossing way barrier Cc:

Description

Validator doesn't find any crossing ways. "Crossing ways" is activated in validator preferences, the crossings are obvious.
This can be reproduced anytime with any data - new "fake" ways crossing without a commmon node and no layer/bridge/tunnel tags and existing data needing cleanup.

Version information:
Plugin validator Version: 19304
JOSM Revision: 2784 (latest)

Attachments (2)

validator-test.osm (1.2 KB) - added by Cobra 11 years ago.
validator_bug_crossing.osm (872 bytes) - added by skyper 11 years ago.
example

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 years ago by bastiK

Keywords: r-2010-01-blocker added

comment:2 Changed 11 years ago by stoecker

Keywords: r-2010-01-blocker removed
Owner: changed from team to Cobra
Status: newneedinfo

Could not reproduce. Please provide examples.

comment:3 Changed 11 years ago by Cobra

I am still able to reproduce this. I suspected some config was broken and unchecked "crossing ways" in the settings/validator dialog, closed and reopened it to check it again, but validator still doesn't find this sort of errors.
Attached .osm file are some simple streets, "foo" and "bar" are crossing without a common node (error 1) and one of bar's end nodes was put near foo (error 2). "baz" is overlapping the second "baz" (error 3). Validator doesn't find the first two errors (which are quite common in bad osm data). The third one is found correctly.

versions:
validator: 19335
josm: r3051

Changed 11 years ago by Cobra

Attachment: validator-test.osm added

comment:4 Changed 11 years ago by skyper

Keywords: crossing way barrier added
Priority: criticalmajor

at least it does not find a barrier crossing a way.

r3144 and o20546

Changed 11 years ago by skyper

Attachment: validator_bug_crossing.osm added

example

comment:5 Changed 11 years ago by skyper

Owner: changed from Cobra to team
Status: needinfonew

comment:6 Changed 11 years ago by Cobra

Resolution: invalid
Status: newclosed

validator is now integrated into core; can't reproduce anymore. closing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.