Modify

Opened 10 years ago

Closed 10 years ago

#4295 closed defect (fixed)

Relations don't update properly

Reported by: NE2 Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

If you open http://www.informationfreeway.org/api/0.6/way[ref=*][bbox=-82,28,-81,29] you get some relations on the right side, all unnamed and without membership information. There seems to be no way to correct this, other than loading the relations as part of the xapi query.

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by vsandre

Summary: No way to load relation after loading some of its elementsAdd 'Update Selection' to right click menu
Type: defectenhancement
Version: tested

This is not a bug of JOSM, because the XAPI-data do not contain any relation-members.

  <relation id='149147' user='NE2' uid='207745' timestamp='2009-12-31T01:31:33Z' version='36' changeset='3495408'>
  </relation>
  <relation id='149149' user='NE2' uid='207745' timestamp='2009-12-31T01:31:37Z' version='34' changeset='3495408'>
  </relation>
  <relation id='189086' user='NE2' uid='207745' timestamp='2010-01-06T09:13:17Z' version='51' changeset='3551681'>
  </relation>
  <relation id='222120' user='NE2' uid='207745' timestamp='2010-01-06T04:56:47Z' version='161' changeset='3550935'>
  </relation>
  <relation id='255717' user='NE2' uid='207745' timestamp='2010-01-05T02:03:55Z' version='37' changeset='3542497'>
  </relation>
  <relation id='269441' user='NE2' uid='207745' timestamp='2010-01-06T15:16:03Z' version='28' changeset='3554385'>
  </relation>
  <relation id='371155' user='NE2' uid='207745' timestamp='2010-01-06T04:56:54Z' version='20' changeset='3550935'>
  </relation>
  <relation id='371156' user='NE2' uid='207745' timestamp='2010-01-06T06:27:31Z' version='7' changeset='3551117'>
  </relation>
  <relation id='371161' user='NE2' uid='207745' timestamp='2010-01-06T04:58:15Z' version='18' changeset='3550935'>
  </relation>
  <relation id='371726' user='NE2' uid='207745' timestamp='2010-01-06T04:58:24Z' version='9' changeset='3550935'>
  </relation>

You can use the josm function UpdateData in the File menu to do what you want.

I changed the ticket to an enhancement. The Update Selection function should be added to the right click menu of a primitive.

comment:2 in reply to:  1 Changed 10 years ago by anonymous

Replying to vsandre:

You can use the josm function UpdateData in the File menu to do what you want.

I changed the ticket to an enhancement. The Update Selection function should be added to the right click menu of a primitive.

oh no, josm redownloads the relation but do not replace it, because the version is the same.

comment:3 Changed 10 years ago by NE2

Summary: Add 'Update Selection' to right click menuRelations don't update properly
Type: enhancementdefect

This is a bug. "Update selection" doesn't fix anything.

comment:4 Changed 10 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2753]) fixed #4295: Relations don't update properly

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.