Modify

Opened 11 years ago

Closed 11 years ago

#4259 closed defect (fixed)

Authentication dialog appears several times while uploading a changeset

Reported by: Atalanttore Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc: nandhp@…

Description

Hi

I'm having some problems with the new authentication dialog of JOSM (v2698). While uploading a changeset I must enter my password several times. Very annoying especially if you have a long password like me.

It seems that I have to enter my password when JOSM

  • creates a new changeset -> authentication dialog
  • uploads the changeset -> authentication dialog
  • is closing the uploaded changeset -> authentication dialog

Regards,
Atalanttore

Attachments (0)

Change History (16)

comment:1 Changed 11 years ago by Atalanttore

No one interested in this bug report?

Additionally, I want to inform you that I do not save my password in the authentication dialog.

comment:2 Changed 11 years ago by nandhp@…

Cc: nandhp@… added

I am having the same problem, and furthermore the enter key appears not to work to submit the dialog (on Windows and Linux). Earlier versions of JOSM (e.g. before multiple changesets) used to cache the username and password until the program exited. This was very handy. It would be nice if this behaviour could be restored.

comment:3 Changed 11 years ago by bastiK

Ticket #5156 has been marked as a duplicate of this ticket.

comment:4 Changed 11 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [3344]) fixed #4259 - Authentication dialog appears several times while uploading a changeset

comment:5 Changed 11 years ago by Atalanttore

Resolution: fixed
Status: closedreopened

Unfortunately, the bug still persists in JOSM version ≧3344.

comment:6 Changed 11 years ago by bastiK

Works for me. What is wrong exactly and what are the steps to reproduce?

comment:7 Changed 11 years ago by Atalanttore

The authentication dialog still appears three times while I'm uploading a changeset. Exactly the same buggy behaviour as before. Nothing has changed.

The steps to reproduce (uploading a changeset) are also the same as before.

comment:8 Changed 11 years ago by bastiK

I mainly fixed it because in the applet you cannot save password:

http://josm.openstreetmap.de/download/applet.html

There it works as well for me.

comment:9 Changed 11 years ago by Atalanttore

I don't save my password in the program.

In older JOSM versions (~2500) I entered my OSM password only once per upload and not 3 times like now.

comment:10 Changed 11 years ago by nandhp@…

This bug is still present in r3376.

comment:11 Changed 11 years ago by bastiK

Just tested it on a second machine but couldn't reproduce either. Maybe depends on operating system. Please append status report. (Help -> Show status report)

comment:12 Changed 11 years ago by nandhp@…

I tried a clean configuration first, and couldn't reproduce it, so I tracked down the problem by diffing the JOSM preferences file: The bug occurs if you have a username but no password saved in your preferences. It must be assuming that there is a saved password even if there is just a saved username.

I can upload a status report if you think it's still necessary.

comment:13 Changed 11 years ago by Atalanttore

This bug disappeared out of nowhere as I started JOSM around r3350 the third or fourth time. Since then the authentication dialog works properly.

@bastiK: I wanted to let you know that a while ago, but unfortunately forgotten.

comment:14 in reply to:  12 Changed 11 years ago by Atalanttore

Replying to nandhp@…:

I tried a clean configuration first, and couldn't reproduce it, so I tracked down the problem by diffing the JOSM preferences file: The bug occurs if you have a username but no password saved in your preferences. It must be assuming that there is a saved password even if there is just a saved username.

This could be.
I remind myself that it worked the first time as my username didn't appear by default in the authentication dialog. I had to enter username and password once and it worked.

comment:15 in reply to:  12 Changed 11 years ago by bastiK

Replying to nandhp@…:

I tried a clean configuration first, and couldn't reproduce it, so I tracked down the problem by diffing the JOSM preferences file: The bug occurs if you have a username but no password saved in your preferences. It must be assuming that there is a saved password even if there is just a saved username.

I can upload a status report if you think it's still necessary.

No, I think this is enough info to track down the bug, thanks.

comment:16 Changed 11 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

(In [3513]) fixed #4259 - Authentication dialog appears several times while uploading a changeset

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.