Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4221 closed defect (duplicate)

copy relation to create new.

Reported by: maxugglan Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. klicked on copy relation to create new.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-12-21 02:31:55
Last Changed Author: jttt
Revision: 2668
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-12-20 21:01:25 +0100 (Sun, 20 Dec 2009)
Last Changed Rev: 2668

Memory Usage: 443 MB / 508 MB (34 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found


Plugins: DirectUpload,editgpx,slippymap,validator,walkingpapers,wmsplugin
Plugin DirectUpload Version: 19082
Plugin editgpx Version: 19052
Plugin slippymap Version: 19070
Plugin validator Version: 19072
Plugin walkingpapers Version: 19074
Plugin wmsplugin Version: 18953

java.lang.IllegalStateException: Can't assign a changesetId > 0 to a new primitive. Value of changesetId is 3 031 713
	at org.openstreetmap.josm.data.osm.OsmPrimitive.setChangesetId(OsmPrimitive.java:656)
	at org.openstreetmap.josm.data.osm.OsmPrimitive.cloneFrom(OsmPrimitive.java:1010)
	at org.openstreetmap.josm.data.osm.Relation.cloneFrom(Relation.java:184

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by stoecker

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by stoecker

Closed as duplicate of #4208.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.