Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4207 closed defect (fixed)

getCurrentDataSet() returns null after adding new layers (then null pointers exceptions)

Reported by: anonymous Owned by: team
Priority: blocker Milestone:
Component: Core Version: latest
Keywords: template_report Cc:


What steps will reproduce the problem?

  1. launch josm (latest :2653) and load Vougy (74130) or something else in Haute-Savoie
  2. You can select or draw ways (normal)
  3. Ask for cadastr (F11) for Vougy (Projectino 4 zones, zone 2) 4 The cadastre come (ok) but you cannot draw oe select anymore ! 5 if (and only if) the cadatre layer is on top and hidden (unvisible), you can select or draw ?! 6 then you get this exception.

Please provide any additional information below. Attach a screenshot if

Repository Root:
Build-Date: 2009-12-19 02:32:07
Last Changed Author: jttt
Revision: 2653
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Date: 2009-12-18 20:10:06 +0100 (Fri, 18 Dec 2009)
Last Changed Rev: 2653

Memory Usage: 45 MB / 508 MB (3 MB allocated, but free)
Java version: 1.6.0_16

Plugins: cadastre-fr,remotecontrol
Plugin remotecontrol Version: 18678
Plugin cadastre-fr Version: 19080

	at org.openstreetmap.josm.actions.mapmode.DrawAction.exitMode(
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(
	at org.openstreetmap.josm.actions.mapmode.MapMode.actionPerformed(
	at javax.swing.AbstractButton.fireActionPerformed(
	at javax.swing.AbstractButton$Handler.actionPerformed(
	at javax.swing.DefaultButtonModel.fireActionPerformed(
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(
	at java.awt.AWTEventMulticaster.mouseReleased(
	at java.awt.AWTEventMulticaster.mouseReleased(
	at java.awt.Component.processMouseEvent(
	at javax.swing.JComponent.processMouseEvent(
	at java.awt.Component.processEvent(
	at java.awt.Container.processEvent(
	at java.awt.Component.dispatchEventImpl(
	at java.awt.Container.dispatchEventImpl(
	at java.awt.Component.dispatchEvent(
	at java.awt.LightweightDispatcher.retargetMouseEvent(
	at java.awt.LightweightDispatcher.processMouseEvent(
	at java.awt.LightweightDispatcher.dispatchEvent(
	at java.awt.Container.dispatchEventImpl(
	at java.awt.Window.dispatchEventImpl(
	at java.awt.Component.dispatchEvent(
	at java.awt.EventQueue.dispatchEvent(
	at java.awt.EventDispatchThread.pumpOneEventForFilters(
	at java.awt.EventDispatchThread.pumpEventsForFilter(
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(
	at java.awt.EventDispatchThread.pumpEvents(
	at java.awt.EventDispatchThread.pumpEvents(

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by pieren

Component: Plugin cadastre-frCore
Owner: changed from pieren to team
Priority: normalblocker

Hi, this is not an issue in the plugin but in josm-latest itself. For some unknown reasons, adding a new layer seems to empty the current dataset collection and all functions using getCurrentDataSet() returns a null value.

comment:2 Changed 8 years ago by pieren

I'm not sure if it is related but I can reproduce it by using the "show/hide" layer button on the OSM data layer.

see #4209 - it's the same error

comment:3 Changed 8 years ago by pieren

Summary: Imposible to draw anything with the cadastre plugingetCurrentDataSet() returns null after adding new layers (then null pointers exceptions)

comment:4 Changed 8 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2668]) Fixed #4207 getCurrentDataSet() returns null after adding new layers (then null pointers exceptions); fixed drawing ways with real width

comment:5 Changed 8 years ago by anonymous

Ticket #4209 has been marked as a duplicate of this ticket.

comment:6 Changed 8 years ago by anonymous

Ticket #4211 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment

E-mail address and name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.