Modify

Opened 12 years ago

Closed 12 years ago

#4199 closed defect (fixed)

new version - plugins update vs josm start

Reported by: jezevec Owned by: Gubaer
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

josm (2651) starts earlier then plugins are updated. On josm start is question and after update confirmation josm starts, but plugins are not updated yet. Then some errors reports (plugins disable questions). Plugins are downloaded and uptated some time (seconds) after josm starts. After josm restart seems all OK.

Attachments (0)

Change History (6)

comment:1 Changed 12 years ago by stoecker

Owner: changed from team to jezevec
Status: newneedinfo

What OS do you use?

comment:2 Changed 12 years ago by jezevec

Owner: changed from jezevec to team
Status: needinfonew

Win Vista Business 32bit

comment:3 Changed 12 years ago by stoecker

Owner: changed from team to Gubaer

Hmpf, the code seems to be correct moveUpdatedPlugins() is called at the end of Update task in PluginDownloader.

@Karl: you use Windows, can you have a look? Basically the problem again may be, that Windows does not unlock some files and renaming fails. But as plugins are not yet loaded at that point of code, there should be no locks. Must be an unfreed resource somewhere.

comment:4 Changed 12 years ago by mjulius

On XP the plugin update works as intended.

comment:5 Changed 12 years ago by Gubaer

On Windows 7 I don't have a problem either.

comment:6 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2817]) fixed #3063: Downloading a plugin yields 3 dialogs at the same time: Downloading plugin / You should restart JOSM / Plugin downloaded
fixed #3628: JOSM blocking itself updating broken plugin
fixed #4187: JOSM deleted random files from disk after start (data loss)
fixed #4199: new version - plugins update vs josm start [should be fixed. Be careful if you have two JOSM instances running. Auto-update of plugins in the second instance will fail because plugin files are locked by the first instance]
fixed #4034: JOSM should auto-download plugin list when it hasn't been downloaded before [JOSM now displays a hint]

fixed: splash screen showing again even if plugins are auto-updated
new: progress indication integrated in splash screen
new: cancelable, asynchronous download of plugins from preferences
new: cancelable, asynchronous download of plugin list from plugin download sites
new: asynchronous loading of plugin information, launch of preferences dialog accelerated
refactored: clean up, documentation of plugin management code (PluginHandler)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gubaer.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.