Modify

Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#4193 closed defect (duplicate)

surveyor plugin Error with buttons Church and Restaurant

Reported by: meppen7 Owned by: team
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: surveyor Cc:

Description

Using the the standard: surveyor.source = resource://surveyor.xml

The error message below only pops up when the button 'Church' or 'Restaurant' is pressed.
No error message with the rest of the buttons.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-12-17 02:31:44
Last Changed Author: bastiK
Revision: 2646
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-12-17 00:06:01 +0100 (Thu, 17 Dec 2009)
Last Changed Rev: 2646

Memory Usage: 30 MB / 1016 MB (1 MB allocated, but free)
Java version: 1.6.0_17

Dataset consistency test:
No problems found

Plugins: livegps,surveyor
Plugin livegps Version: 19056
Plugin surveyor Version: 18503

java.lang.NoSuchMethodError: org.openstreetmap.josm.data.osm.DataSet.setSelected([Lorg/openstreetmap/josm/data/osm/OsmPrimitive;)V

at at.dallermassl.josm.plugin.surveyor.action.SetNodeAction.actionPerformed(SetNodeAction.java:73)
at at.dallermassl.josm.plugin.surveyor.SurveyorActionDescription.actionPerformed(SurveyorActionDescription.java:88)
at at.dallermassl.josm.plugin.surveyor.MetaAction.actionPerformed(MetaAction.java:101)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 by meppen7, 15 years ago

See also ticket 4177, sorry for double

comment:2 by stoecker, 15 years ago

Resolution: duplicate
Status: newclosed

comment:3 by stoecker, 15 years ago

Closed as duplicate of #4177.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.