Modify

Opened 10 years ago

Closed 10 years ago

#4141 closed defect (fixed)

conflict detection too strict for node coordinates

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I have uploaded an osm-file. Upload did not finish and josm did not response anymore.
I had to kill it without saving.
I started josm again and updated the data from the server. I got 260 conficts with nodes without any changes. JOSM said the position were not the same but it was.

attach osm-file, only update from server
version 2595

Attachments (2)

stühlinger12_update.osm (1.8 MB) - added by skyper 10 years ago.
CoordinateConflictPrecision.patch (3.5 KB) - added by mjulius 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by skyper

Attachment: stühlinger12_update.osm added

comment:1 Changed 10 years ago by skyper

If this is not a bug, please have some possibility to automate the conflict management. I had to click threetimes on every conflict to set the positions right.

comment:2 Changed 10 years ago by mjulius

Summary: 260 conficts without one conflict.conflict detection too strict for node coordinates

JOSM is too strict when comparing node coordinates. It only shows 4 decimals in the conflict dialog but there are a lot more. If someone has modified the node without moving the node and his editor was rounding the coordinates a little bit you will get a conflict and the coordinates will look the same in the conflict dialog.

JOSM needs to relax a little bit and it needs to show all relevant digits.

Changed 10 years ago by mjulius

comment:3 Changed 10 years ago by mjulius

Summary: conflict detection too strict for node coordinates[Patch] conflict detection too strict for node coordinates

The API actually returns only 7 decimals for coordinates. Therefore, the attached patch sets the MAX_SERVER_PRECISION to 5e-8 and displays 7 decimals in the conflict resolution dialog.

comment:4 Changed 10 years ago by mjulius

Resolution: fixed
Status: newclosed

(In [2612]) Fixes #4083 - exception when copying relation with incomplete node
Fixes #4141 - relax conflict detection for coordinates; API only returns 7 decimals

comment:5 Changed 10 years ago by skyper

Resolution: fixed
Status: closedreopened

I think it is not yet done.

I have updated the first osm and I got a lot of conflicts, because a lot of nodes were already uploaded.
Conflict said that nodes are deleted on my osm but in fact they existed with id:0.

Conflict management should notice that.

I have attached an osm of this region just downloaded from server that it should be possible to merge these two osm form debugging.

version 2670

comment:6 Changed 10 years ago by skyper

Summary: [Patch] conflict detection too strict for node coordinatesconflict detection too strict for node coordinates

comment:7 Changed 10 years ago by mjulius

Resolution: fixed
Status: reopenedclosed

This is a different issue. I agree that JOSM should try to match newly downloaded primitives to existing new ones (see #4223), but this is not necessarily a conflict.

When updating your data JOSM first reports 15 conflicts and then tells me that there are 454 primitives in the local data that might have been deleted on the server. This is because the server did not return those when JOSM was downloading the bounding box defined in your data. Checking the server for those does not produce any additional conflicts. There are no conflicts on nodes.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.