Modify

Opened 12 years ago

Closed 10 years ago

#4125 closed defect (invalid)

Paste of large amount of text into a preset dialog causes it to hang

Reported by: AM909 Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: preset hang Cc:

Description (last modified by simon04)

If you (accidentally) try to apply a preset that pops up a dialog (e.g. Highways->Streets->Primary), and then paste into a field when there is a large* amount of text on the clipboard, the dialog becomes non-responsive, as does JOSM entirely, since these dialogs are modal.

This happens with v2255, and I didn't find a relevant ticket, so I am creating this one assuming it has not been fixed. I'll test and update the ticket when I get the recent tested version (soon).

*I think I had a copy of elemstyles.xml on the clipboard - about 120KB.

I was able to connect to the remote-control plugin, give it an import command, which caused a popup to appear from JOSM asking for confirmation, which then gave me control of JOSM back again.

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by simon04

Description: modified (diff)
Resolution: invalid
Status: newclosed

I don't see a chance to fix this within JOSM. Trying to reproduce this with the contents of the current defaulpresets.xml (≈400kB), has no effect.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.