Modify

Opened 10 years ago

Closed 10 years ago

#4100 closed defect (fixed)

unable to simply load already referenced images

Reported by: malenki Owned by: bastiK
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc: malenki

Description

Since the AgPifoJ-Plugin was built into Josm one can't load already georeferenced pictures as it was possible with the plugin.

At the moment one _has_to_ open some track (downloaded GPSpoints won't do) to be able to load referenced Images.

Desired behaviour: a function to plainly load Images

Attachments (0)

Change History (11)

comment:1 Changed 10 years ago by malenki

Version: latest

comment:2 Changed 10 years ago by malenki

latest, that is: Josm version 2574

comment:3 Changed 10 years ago by malenki

Cc: malenki added

comment:4 Changed 10 years ago by bastiK

I haven't thought of that. Thanks for reporting.

comment:5 Changed 10 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [2702]) fixed #4100 - unable to simply load already referenced images
Added 'jpg' to the list of available formats for 'File' > 'Open...'

comment:6 Changed 10 years ago by anonymous

Ticket #4264 has been marked as a duplicate of this ticket.

comment:7 Changed 10 years ago by malenki

Resolution: fixed
Status: closedreopened

This function is broken. Trying to open referenced images with the Open-dialog gives two errors.

At first, Josm sais "Opening 1 file..." and in foreground an message pops up:

Could not read files:

Error is:

null

The related output at bash is
java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer.create(GeoImageLayer.java:265)
at org.openstreetmap.josm.io.JpgImporter.importData(JpgImporter.java:39)
at org.openstreetmap.josm.io.FileImporter.importDataHandleExceptions(FileImporter.java:68)
at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:164)
at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:149)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:81)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:123)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

After clicking [OK] the second error message pops up:

java.lang.NullPointerException

The related output at bash is:
java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer.<init>(GeoImageLayer.java:277)
at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer.<init>(GeoImageLayer.java:71)
at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer$Loader.realRun(GeoImageLayer.java:156)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:81)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:123)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

java.lang.NullPointerException

at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer.<init>(GeoImageLayer.java:277)
at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer.<init>(GeoImageLayer.java:71)
at org.openstreetmap.josm.gui.layer.geoimage.GeoImageLayer$Loader.realRun(GeoImageLayer.java:156)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:81)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:123)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Tried with josm 2709 and 2710.

comment:8 Changed 10 years ago by stoecker

Ticket #4267 has been marked as a duplicate of this ticket.

comment:9 Changed 10 years ago by stoecker

Ticket #4273 has been marked as a duplicate of this ticket.

comment:10 Changed 10 years ago by stoecker

Owner: changed from team to bastiK
Status: reopenednew

Reason: There is no Main.map available when loading an image using open without previously loading data.

comment:11 Changed 10 years ago by bastiK

Resolution: fixed
Status: newclosed

(In [2720]) fixed #4100 (no Main.map available when loading an image using open without previously loading data)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.