Modify

Opened 10 years ago

Closed 10 years ago

#4028 closed defect (worksforme)

java.lang.ArrayIndexOutOfBoundsException when using Lakewalker

Reported by: avarab@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by stoecker)

I'm not sure if this is a lakewalker bug or a general issue:

Build-Date: 2009-11-26 15:25:20		
Revision: 2516
Is-Local-Build: true

Memory Usage: 986 MB / 986 MB (276 MB allocated, but free)
Java version: 1.6.0_16

Dataset consistency test:
No problems found


Plugins: lakewalkermultipolyopenstreetbugsopenvisibleremotecontrolslippymaputilspluginvalidatorwalkingpaperswmsplugin
Plugin lakewalker Version: 17375
Plugin multipoly Version: 18415
Plugin openstreetbugs Version: 18595
Plugin openvisible Version: 17536
Plugin remotecontrol Version: 18678
Plugin slippymap Version: 18741
Plugin utilsplugin Version: 18621
Plugin validator Version: 18623
Plugin walkingpapers Version: 18597
Plugin wmsplugin Version: 18712

java.lang.ArrayIndexOutOfBoundsException: 0
	at javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1356)
	at javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1299)
	at javax.swing.plaf.basic.BasicListUI.paintImpl(BasicListUI.java:251)
	at javax.swing.plaf.basic.BasicListUI.paint(BasicListUI.java:227)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:143)
	at javax.swing.JComponent.paintComponent(JComponent.java:763)
	at javax.swing.JComponent.paint(JComponent.java:1029)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5124)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1475)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1406)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:294)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1220)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5072)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4882)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:803)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:714)
	at javax.swing.RepaintManager.seqPaintDirtyRegions(RepaintManager.java:694)
	at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:128)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by stoecker

Description: modified (diff)
Resolution: worksforme
Status: newclosed

Seems to be more like a Java bug. No josm code involved. Can you make this reproducable, then reopen report.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.