Modify

Opened 12 years ago

Closed 12 years ago

#3944 closed defect (worksforme)

Absturz beim Öffnen der Vorlage Café aus dem Menü

Reported by: Creando Owned by: Creando
Priority: major Milestone:
Component: Core Version: tested
Keywords: Cc:

Description

Nach Öffnen der Vorlage für Cafés aus dem Kopfzeilenmenü mit dem Restaurantsymbol kam eine Fehlermeldung, diese erschien nach wegclicken immer wieder und mit JOSM konnte nicht mehr weiter gearbeitet werden. Das Programm musste zwangsbeendet werden mit Verlust aller noch nicht hochgeladenen Daten.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 2255
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 2255
Last Changed Date: 2009-10-07 21:25:15 +0200 (Wed, 07 Oct 2009)

Memory Usage: 56 MB / 63 MB (8 MB allocated, but free)
Java version: 1.5.0_19

java.lang.IllegalArgumentException: Invalid substring range

at java.text.AttributedString$AttributedStringIterator.<init>(AttributedString.java:721)
at java.text.AttributedString.getIterator(AttributedString.java:548)
at javax.swing.text.Utilities.drawComposedText(Utilities.java:851)
at javax.swing.text.PlainView.drawElement(PlainView.java:90)
at javax.swing.text.PlainView.drawLine(PlainView.java:71)
at javax.swing.text.PlainView.paint(PlainView.java:288)
at javax.swing.text.FieldView.paint(FieldView.java:171)
at javax.swing.plaf.basic.BasicTextUI$RootView.paint(BasicTextUI.java:1339)
at javax.swing.plaf.basic.BasicTextUI.paintSafely(BasicTextUI.java:644)
at javax.swing.plaf.basic.BasicTextUI.paint(BasicTextUI.java:782)
at javax.swing.plaf.basic.BasicTextUI.update(BasicTextUI.java:761)
at javax.swing.JComponent.paintComponent(JComponent.java:743)
at javax.swing.JComponent.paint(JComponent.java:1006)
at javax.swing.JComponent._paintImmediately(JComponent.java:4890)
at javax.swing.JComponent.paintImmediately(JComponent.java:4676)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:477)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:114)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:180)
at java.awt.Dialog$1.run(Dialog.java:535)
at java.awt.Dialog$2.run(Dialog.java:565)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:563)
at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:843)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.handleException(BugReportExceptionHandler.java:54)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.uncaughtException(BugReportExceptionHandler.java:33)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:983)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:978)
at apple.awt.CToolkit$EventQueueExceptionHandler.handle(CToolkit.java:83)
at sun.reflect.GeneratedMethodAccessor38.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at java.awt.EventDispatchThread.handleException(EventDispatchThread.java:382)
at java.awt.EventDispatchThread.processException(EventDispatchThread.java:288)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:280)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:180)
at java.awt.Dialog$1.run(Dialog.java:535)
at java.awt.Dialog$2.run(Dialog.java:565)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:563)
at java.awt.Component.show(Component.java:1302)
at java.awt.Component.setVisible(Component.java:1255)
at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:308)
at org.openstreetmap.josm.gui.tagging.TaggingPreset$1PresetDialog.<init>(TaggingPreset.java:749)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.actionPerformed(TaggingPreset.java:753)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1882)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2202)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
at javax.swing.AbstractButton.doClick(AbstractButton.java:334)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1051)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1092)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
at java.awt.Component.processMouseEvent(Component.java:5583)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5348)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4050)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3885)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1791)
at java.awt.Component.dispatchEvent(Component.java:3885)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by anonymous

Owner: changed from team to Creando
Status: newneedinfo

Could not reproduce it with latest 2466 or tested 2255

comment:2 Changed 12 years ago by Gubaer

Resolution: worksforme
Status: needinfoclosed

Neither can I. Closing as worksforme.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Creando.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.