Modify

Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#3929 closed defect (wontfix)

OutOfMemoryError while opening .OSM file

Reported by: anonymous Owned by: team
Priority: major Milestone:
Component: Core Version: tested
Keywords: RuntimeException, OutOfMemoryError Cc:

Description (last modified by Gubaer)

Hi,
JOSM asked me to create an error report after something crashed. I've been loading a file with some OSM data while it crashed. Said file contained the insides of a polygon surrounding my local area. The data has been extracted by osmosis out of the following file:
http://download.geofabrik.de/osm/europe/germany/nordrhein-westfalen.osm.bz2
I assume the area has simply been too large, and I assume that this bug has been reported before, but I'm new with OSM and therefore I can be too lazy to find out how this bug tracker works. I don't know if this matters, but I'm using debian/stable.
I've attached the osmosis file with the polygon data so that you can reproduce the error, if you are interested.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 2255
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 2255
Last Changed Date: 2009-10-07 21:25:15 +0200 (Wed, 07 Oct 2009)

Memory Usage: 81 MB / 81 MB (62 MB allocated, but free)
Java version: 1.5.0_17

Plugins: PicLayerdataimportgraphviewopenstreetbugsopenvisibleplastic_lafutilspluginwaydownloader
Plugin plastic_laf Version: 14016
Plugin PicLayer Version: 17327
Plugin dataimport Version: 18071
Plugin graphview Version: 18130
Plugin openstreetbugs Version: 17872
Plugin openvisible Version: 17536
Plugin utilsplugin Version: 17707
Plugin waydownloader Version: 18067

java.lang.RuntimeException: java.lang.OutOfMemoryError: Java heap space

at org.openstreetmap.josm.gui.PleaseWaitRunnable$2.run(PleaseWaitRunnable.java:98)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Caused by: java.lang.OutOfMemoryError: Java heap space

at org.openstreetmap.josm.io.OsmReader$Parser.startElement(OsmReader.java:219)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.startElement(AbstractSAXParser.java:533)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:878)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1693)
at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:368)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:834)
at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:764)
at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:148)
at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1242)
at javax.xml.parsers.SAXParser.parse(SAXParser.java:375)
at org.openstreetmap.josm.io.OsmReader.parseDataSet(OsmReader.java:534)
at org.openstreetmap.josm.io.OsmImporter.importData(OsmImporter.java:41)
at org.openstreetmap.josm.io.OsmImporter.importData(OsmImporter.java:33)
at org.openstreetmap.josm.actions.OpenFileAction.openFile(OpenFileAction.java:57)
at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:88)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:62)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:116)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:417)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
at java.util.concurrent.FutureTask.run(FutureTask.java:123)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
at java.lang.Thread.run(Thread.java:595)


homezone
1

7.180246 51.100316
7.051157 51.164948
6.887735 51.161503
6.790232 51.100316
6.794352 51.026092
6.890482 50.974238
7.088236 50.977697
7.178873 51.034729
7.180246 51.096004

END
END

Attachments (0)

Change History (3)

comment:1 Changed 13 years ago by anonymous

Summary: Got an error, just leaving this hereOutOfMemoryError while opening .OSM file

comment:2 Changed 13 years ago by Gubaer

Description: modified (diff)
Resolution: wontfix
Status: newclosed

Try to run JOSM with more memory, i.e. java -Xmx256m -jar josm-latest.jar

comment:3 Changed 12 years ago by anonymous

Probably my question is stupid, but anyway, how can I run JOSM with more memory? I run it clicking on its icon, and there isn´t any place (with .jar or .jnlp) to choose the memory or type that (Xmx)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.