Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3913 closed defect (duplicate)

alt-U in name dialoge produces persistent error message

Reported by: Polarbear Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Trying to enter 'Citroën' using the alt-U e combination in MacOS.

The error comes up already when doing the alt-U, before the e.

Particularly nasty since the error dialog came up again and again when being closed,
so in the end I had to shut JOSM down.

Did reproduce with a freshly started JOSM.

Build-Date: 2009-11-07 23:15:57
Is-Local-Build: true
Revision: 2394

Memory Usage: 690 MB / 1016 MB (256 MB allocated, but free)
Java version: 1.5.0_20

Plugins: PicLayerdataimportlakewalkerlivegpsmeasurementslippymaputilspluginvalidatorwmsplugin
Plugin PicLayer Version: 17327
Plugin dataimport Version: 18071
Plugin lakewalker Version: 17375
Plugin livegps Version: 18408
Plugin measurement Version: 17377
Plugin slippymap Version: 18485
Plugin utilsplugin Version: 18415
Plugin validator Version: 18453
Plugin wmsplugin Version: 18408

java.lang.IllegalArgumentException: Invalid substring range

at java.text.AttributedString$AttributedStringIterator.<init>(AttributedString.java:721)
at java.text.AttributedString.getIterator(AttributedString.java:548)
at javax.swing.text.Utilities.drawComposedText(Utilities.java:851)
at javax.swing.text.PlainView.drawElement(PlainView.java:90)
at javax.swing.text.PlainView.drawLine(PlainView.java:71)
at javax.swing.text.PlainView.paint(PlainView.java:288)
at javax.swing.text.FieldView.paint(FieldView.java:171)
at javax.swing.plaf.basic.BasicTextUI$RootView.paint(BasicTextUI.java:1339)
at javax.swing.plaf.basic.BasicTextUI.paintSafely(BasicTextUI.java:644)
at javax.swing.plaf.basic.BasicTextUI.paint(BasicTextUI.java:782)
at javax.swing.plaf.basic.BasicTextUI.update(BasicTextUI.java:761)
at javax.swing.JComponent.paintComponent(JComponent.java:743)
at javax.swing.JComponent.paint(JComponent.java:1006)
at javax.swing.JComponent._paintImmediately(JComponent.java:4890)
at javax.swing.JComponent.paintImmediately(JComponent.java:4676)
at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:477)
at javax.swing.SystemEventQueueUtilities$ComponentWorkRequest.run(SystemEventQueueUtilities.java:114)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:180)
at java.awt.Dialog$1.run(Dialog.java:535)
at java.awt.Dialog$2.run(Dialog.java:565)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:563)
at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:843)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.handleException(BugReportExceptionHandler.java:54)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.uncaughtException(BugReportExceptionHandler.java:33)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:983)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:978)
at apple.awt.CToolkit$EventQueueExceptionHandler.handle(CToolkit.java:87)
at sun.reflect.GeneratedMethodAccessor48.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:592)
at java.awt.EventDispatchThread.handleException(EventDispatchThread.java:382)
at java.awt.EventDispatchThread.processException(EventDispatchThread.java:288)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:280)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:180)
at java.awt.Dialog$1.run(Dialog.java:535)
at java.awt.Dialog$2.run(Dialog.java:565)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:563)
at java.awt.Component.show(Component.java:1302)
at java.awt.Component.setVisible(Component.java:1255)
at org.openstreetmap.josm.gui.ExtendedDialog.setVisible(ExtendedDialog.java:328)
at org.openstreetmap.josm.gui.tagging.TaggingPreset$1PresetDialog.<init>(TaggingPreset.java:747)
at org.openstreetmap.josm.gui.tagging.TaggingPreset.actionPerformed(TaggingPreset.java:751)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1882)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2202)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
at javax.swing.AbstractButton.doClick(AbstractButton.java:334)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1051)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1092)
at java.awt.Component.processMouseEvent(Component.java:5602)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5367)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4068)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1801)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Attachments (0)

Change History (2)

comment:1 Changed 13 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 13 years ago by anonymous

Closed as duplicate of #2221.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.