Modify

Opened 12 years ago

Closed 12 years ago

#3908 closed defect (fixed)

Exception when updating a way

Reported by: mjulius Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I just did the following in r2439:

  • Download an area from API
  • Select a way
  • Do "Update selections"

JOSM here shows an error dialog saying "java.lang.RuntimeException: Missing merge target for way with id 18,803,947".

The selected way actually has the ID 3770585 and the one mentioned in the error message happens to be the one of the first node in the way.

The "Update data" command does not have this problem.

Furthermore, the error dialog has a "Help" button. When clicking on that there is another popup from the Java Virtual Machine Launcher saying "Could not find the main class. Program will exit." This is on WinXP 32 bit with Java 1.6.0_02.

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by anonymous

The same here.

GET http://www.openstreetmap.org/api/0.6/nodes?nodes=560748351,560748349
GET http://www.openstreetmap.org/api/0.6/ways?ways=44132902
12.11.2009 16:36:33 org.openstreetmap.josm.io.OsmReader processWaysAfterParsing
WARNUNG: Der Weg mit der ID 44.132.902 wird als unvollstõndig markiert, weil min
destens einer seiner 2 Knoten in den geladenen Daten fehlt.
org.openstreetmap.josm.io.OsmTransferException: java.lang.RuntimeException: Miss
ing merge target for way with id 560.748.349
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.multiGetIdPack
age(MultiFetchServerObjectReader.java:319)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.fetchPrimitive
s(MultiFetchServerObjectReader.java:413)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.parseOsm(Multi
FetchServerObjectReader.java:452)
        at org.openstreetmap.josm.actions.UpdateSelectionAction$UpdatePrimitives
Task.realRun(UpdateSelectionAction.java:214)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRun
nable.java:63)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.
java:105)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source
)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Missing merge target for way with id 560.
748.349
        at org.openstreetmap.josm.data.osm.DataSetMerger.getMergeTarget(DataSetM
erger.java:137)
        at org.openstreetmap.josm.data.osm.DataSetMerger.mergeNodeList(DataSetMe
rger.java:178)
        at org.openstreetmap.josm.data.osm.DataSetMerger.fixReferences(DataSetMe
rger.java:160)
        at org.openstreetmap.josm.data.osm.DataSetMerger.merge(DataSetMerger.jav
a:359)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.merge(MultiFet
chServerObjectReader.java:390)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.multiGetIdPack
age(MultiFetchServerObjectReader.java:315)
        ... 11 more
org.openstreetmap.josm.io.OsmTransferException: java.lang.RuntimeException: Miss
ing merge target for way with id 560.748.349
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.multiGetIdPack
age(MultiFetchServerObjectReader.java:319)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.fetchPrimitive
s(MultiFetchServerObjectReader.java:413)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.parseOsm(Multi
FetchServerObjectReader.java:452)
        at org.openstreetmap.josm.actions.UpdateSelectionAction$UpdatePrimitives
Task.realRun(UpdateSelectionAction.java:214)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRun
nable.java:63)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.
java:105)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source
)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.RuntimeException: Missing merge target for way with id 560.
748.349
        at org.openstreetmap.josm.data.osm.DataSetMerger.getMergeTarget(DataSetM
erger.java:137)
        at org.openstreetmap.josm.data.osm.DataSetMerger.mergeNodeList(DataSetMe
rger.java:178)
        at org.openstreetmap.josm.data.osm.DataSetMerger.fixReferences(DataSetMe
rger.java:160)
        at org.openstreetmap.josm.data.osm.DataSetMerger.merge(DataSetMerger.jav
a:359)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.merge(MultiFet
chServerObjectReader.java:390)
        at org.openstreetmap.josm.io.MultiFetchServerObjectReader.multiGetIdPack
age(MultiFetchServerObjectReader.java:315)
        ... 11 more

comment:2 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2444]) fixed #3908: Exception when updating a way
fixed a few I18n issues

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.