Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3787 closed defect (fixed)

[PATCH] Select duplicated objects

Reported by: malenki Owned by: hansendc
Priority: normal Milestone:
Component: Core Version: latest
Keywords: select duplicate Cc:

Description

Up to version ~2300 (or some before) Josm did automatically select objects which were duplicated. Now this behaviour disappeared I miss it much.

It is very helpful duplicating ways with more than one parts - one hasn't to select every bit anew to move it.
It is helpful at duplicating adresses: with the old behaviour the newly created node was already selected, one had just to change the number, done. Now one has to select the new created node before one can edit it: twice the work one had before.

Please give back the old behaviour.

Attachments (1)

fix-paste-selection.patch (1.7 KB) - added by hansendc 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by anonymous

Owner: changed from team to hansendc

comment:2 Changed 10 years ago by hansendc

Are you talking about copy-and-paste? I'm not quite understanding the exact sequence of events that you do.

In any case, I think this was introduced by changeset 2305 (which wasn't my patch):

http://josm.openstreetmap.de/changeset/2305

It commented out this line in PasteAction:

getCurrentDataSet().setSelected(osms);

and never replaced it with anything. I believe the attached patch fixes it.

Changed 10 years ago by hansendc

Attachment: fix-paste-selection.patch added

comment:3 Changed 10 years ago by Daeron

Summary: Select duplicated objects[PATCH] Select duplicated objects

comment:4 Changed 10 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2349]) applied #3787: patch by hansendc: Select duplicated objects

comment:5 Changed 10 years ago by avarab@…

Ticket #3808 has been marked as a duplicate of this ticket.

comment:6 Changed 10 years ago by malenki

Thanks for the fast fix.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain hansendc.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.