Modify

Opened 12 years ago

Closed 12 years ago

#3748 closed defect (fixed)

Selecting relation member in properties windows often keeps key/value selected as well

Reported by: Ldp Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

If I select an object that is a member of a relation, and I click on the relation in the 'Member Of' section of the Properties window, the relation is selected, but often the first key/value also stays selected. If I then try to 'Delete' the object from the relation, the key is removed instead.

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.7.1
Created-By: 14.1-b02 (Sun Microsystems Inc.)
Main-class: JOSM
Main-Version: 2300 SVN
Main-Date: 2009-10-18T18:19:40.122791Z
Memory Usage: 22 MB / 1016 MB (1 MB allocated, but free)
Java version: 1.6.0_15

Attachments (0)

Change History (5)

comment:1 Changed 12 years ago by Gubaer

Resolution: worksforme
Status: newclosed

Hmm, can't reproduce. I've tried dozens of click sequences but it didn't happen. Closing as worksforme. Let me know if you're aware of specific click sequence which will lead to the problem described here.

comment:3 Changed 12 years ago by stoecker

Resolution: worksforme
Status: closedreopened

comment:4 Changed 12 years ago by Daeron

I found a reliable way to reproduce this:

Select a tag, then click-drag on top of the membership. This leaves both selected.

Also happens the other way: if the membership was selected and click drag is performed on top of a tag.

comment:5 Changed 12 years ago by bastiK

Resolution: fixed
Status: reopenedclosed

(In [2383]) fix #3748: Selecting relation member in properties windows often keeps key/value selected as well

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.