Modify

Opened 15 years ago

Closed 15 years ago

#3556 closed defect (fixed)

False positive conflicts when merging nodes

Reported by: pieren Owned by: Gubaer
Priority: critical Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

False conflicts appears on latest josm tests:

  • create two new empty nodes A and B
  • add on node A a dummy tag (e.g. "bla"="bla")
  • merge with empty node B

It creates a conflict where it shouldn't. Tag "bla" doesn't exists in node B.

Attachments (0)

Change History (10)

comment:1 by Gubaer, 15 years ago

Resolution: wontfix
Status: newclosed

This was introduced due to another ticket (don't remember the id any more).

The very fact that "bla" doesn't exist on B *is* in conflict that it exists on B. How should the merged node look like? Should it have a tag "bla"="bla" or not? Some users expect it to have the tag, other don't and a third group would like to decide from case to case.

JOSM now displays a conflict dialog. The default decision is to keep "bla"="bla" but you can override it by selecting the value "None" in the list of possible values for the tag "bla".

comment:2 by pieren, 15 years ago

Resolution: wontfix
Status: closedreopened

Wow, this will be a big change from the JOSM behaviour for merging. I belong to the group who expect a conflict when there is a real conflict (two keys, different values) and clean-up tag combinations only when it is necessary, otherwise I don't merge.

May I suggest to make this new behaviour configurable ? My guess is that you will have a lot of complains about this additional dialog.

in reply to:  2 comment:3 by Gubaer, 15 years ago

May I suggest to make this new behaviour configurable ? My guess is that you will have a lot of complains about this additional dialog.

Not yet, yours is the the first one :-)

Except perhaps #3460, but this one complains about a slightly different aspect of the new conflict resolution dialog.

comment:4 by pieren, 15 years ago

I think I understand now why this is really annoying. Even when you combine a complete new and empty way (or an empty node), we have now this dialog. When you merge or combine something existing with some new element, we don't expect such dialog (which could be understandable if both elements carry some information).

comment:5 by stoecker, 15 years ago

Maybe make omit the dialog when only one joined element has tags at all? That should solve most of the annoyance without losing the better information.

in reply to:  5 comment:6 by Gubaer, 15 years ago

Owner: changed from team to Gubaer
Status: reopenednew

Replying to stoecker:

Maybe make omit the dialog when only one joined element has tags at all? That should solve most of the annoyance without losing the better information.

Yes, I think so too. I'll see what I can do.

comment:7 by stoecker, 15 years ago

Ticket #3103 has been marked as a duplicate of this ticket.

comment:8 by stoecker, 15 years ago

Ticket #3460 has been marked as a duplicate of this ticket.

comment:9 by stoecker, 15 years ago

The other reports are about combining ways, but the issue is the same.

comment:10 by Gubaer, 15 years ago

Resolution: fixed
Status: newclosed

(In [2220]) fixed #3556: False positive conflicts when merging nodes
fixed #3460: show only conflicting tags at conflict resolution dialog
fixed #3103: resolve conflicts after combining just one conflict

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gubaer.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.