Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3337 closed defect (fixed)

RuntimeException: java.lang.StackOverflowError in gui.PleaseWaitRunnable

Reported by: phobie Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: update data RuntimeException StackOverflowError relation containing itself Cc:

Description

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1997
Node Kind: directory
Last Changed Author: Gubaer
Last Changed Rev: 1997
Last Changed Date: 2009-08-25 22:45:57 +0200 (Tue, 25 Aug 2009)


Memory Usage: 90 MB / 986 MB (15 MB allocated, but free)
Java version: 1.6.0_0

Plugins: measurementopenstreetbugsplastic_lafremotecontrolslippymaptageditortagging-preset-testerusertoolsutilspluginvalidatorwaydownloaderwmsplugin
Plugin plastic_laf Version: 14016
Plugin measurement Version: 16801
Plugin openstreetbugs Version: 17035
Plugin remotecontrol Version: 16965
Plugin slippymap Version: 16805
Plugin tageditor Version: 16919
Plugin tagging-preset-tester Version: 14015
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16735
Plugin validator Version: 17175
Plugin waydownloader Version: 16963
Plugin wmsplugin Version: 16872


java.lang.RuntimeException: java.lang.StackOverflowError
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$2.run(PleaseWaitRunnable.java:98)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Caused by: java.lang.StackOverflowError
	at org.openstreetmap.josm.data.osm.Way.getNodes(Way.java:41)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:185)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.appendGeneric(MultiFetchServerObjectReader.java:216)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:206)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.appendGeneric(MultiFetchServerObjectReader.java:218)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:206)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.appendGeneric(MultiFetchServerObjectReader.java:218)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:206)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.appendGeneric(MultiFetchServerObjectReader.java:218)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:206)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.appendGeneric(MultiFetchServerObjectReader.java:218)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:206)
[repeated many times]
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.appendGeneric(MultiFetchServerObjectReader.java:218)
	at org.openstreetmap.josm.io.MultiFetchServerObjectReader.append(MultiFetchServerObjectReader.java:206)

Attachments (0)

Change History (3)

comment:1 Changed 12 years ago by plaicy

It sounds like you got a relation containing itself. The posted url does not contain any relations and works for me. Maybe you tested a different gpx file.

comment:2 Changed 12 years ago by phobie

Keywords: relation containing itself added

Yes, that is because I changes note:DE to note:de!
http://tagwatch.stoecker.eu/osmxapi/*%5Bnote%3Ade=*%5D contains the problematic relation.

I searched through the data and found a problematic relation at http://api.openstreetmap.org/browse/relation/197999 .

Since the OSM-API supports such "errors", JOSM should at least not run into a exception!

comment:3 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2000]) fixed #3337: RuntimeException: java.lang.StackOverflowError in gui.PleaseWaitRunnable

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.