Modify

Opened 10 years ago

Closed 6 years ago

#3292 closed enhancement (duplicate)

Missing the familiar right-click behaviour

Reported by: vsandre Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

For instance in the download menu tab Cordinates you have to use CTRL + V to paste in the OSM url. I am expecting to use the right-click menu and then paste, especially as a tablet-pc user. Is there a way to implement this or even to create a button to paste the clipboard.

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by plaicy

http://www.javalobby.org/java/forums/t19867.html mention at least three four:

  1. replace every text component
  2. add eventlistener to every component
  3. replace event queue
  4. add some sort of awtlistener

Every solution needs a lot of testing. So think this request should be postponed until next testing release of JOSM. I would prefer the first solution because for autocompletion most text component (I think) must use a custom class already.

comment:2 Changed 10 years ago by bastiK

Ticket #2276 has been marked as a duplicate of this ticket.

comment:3 Changed 9 years ago by stoecker

Ticket #4580 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #4429.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.